Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Install extension silently in Firefox 41

  • 3 replies
  • 1 has this problem
  • 5536 views
  • Last reply by iRomul

more options

I'm making automatic installer for special Firefox extensions. I have read couple of articles about that, but none of the described methods are not helped. What I tried to do:

- Placed .xpi file and unpacked unpacked extension directory in %FF_DIR%\browser\extensions
- Placed .xpi file and unpacked unpacked extension directory in %FF_DIR%\extensions
- Placed unpacked extension directory in another directory and added record in registry (`HKLM\Software\Mozilla\Firefox\extensions`, key is extension id and value is full path to unpacked extension)

In all ways name of unpacked extension directory was:

- Random name
- ID from install.rdf #1 (`{ec8030f7-c20a-464f-9b0e-13a3a9e97384}` for example)
- ID from install.rdf #2 (`prism@developer.mozilla.org` for example)  

And, as i said, all methods don't give me expectable result. Firefox don't show extensions in list and don't show any notification. How can i solve it? What actual method using in current version of FF? Target browser is Firefox 41, system - Windows 7 x64 Thanks!

Chosen solution

See also:

{ec8030f7-c20a-464f-9b0e-13a3a9e97384} is the GUID of Firefox and not the ID of the extension, so make sure to use the ID of the extension under Description > id and not the 'id' listed under 'targetApplication' and surround a GUID with curly brackets and append the .xpi file extension.

  • {8A6C82A1-F6C9-481a-AAE7-C96444C9A754}.xpi
  • prism@developer.mozilla.org.xpi
Read this answer in context 👍 1

All Replies (3)

more options

Support Forum is for general problem. It will be better if you ask help in proper channel. As far as I know these are the valid and most proper channels for seeking help about addons:

Hope you will get help from these links.

more options

Chosen Solution

See also:

{ec8030f7-c20a-464f-9b0e-13a3a9e97384} is the GUID of Firefox and not the ID of the extension, so make sure to use the ID of the extension under Description > id and not the 'id' listed under 'targetApplication' and surround a GUID with curly brackets and append the .xpi file extension.

  • {8A6C82A1-F6C9-481a-AAE7-C96444C9A754}.xpi
  • prism@developer.mozilla.org.xpi
more options

cor-el said

See also: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} is the GUID of Firefox and not the ID of the extension, so make sure to use the ID of the extension under Description > id and not the 'id' listed under 'targetApplication' and surround a GUID with curly brackets and append the .xpi file extension.
  • {8A6C82A1-F6C9-481a-AAE7-C96444C9A754}.xpi
  • prism@developer.mozilla.org.xpi

Thank you! In fact - I used an incorrect ID (both from "targetApplication"). Now I was able to install the plug-in by copying plugin directory to %FF_DIR%\browser\extensions.

Modified by iRomul