Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is watch now news videos missing on Fox News .com

  • 6 replies
  • 8 have this problem
  • 5 views
  • Last reply by cor-el

more options

No videos appear in the right column under Watch Now on Fox News home page.

All Replies (6)

more options

Are you using any kind of blocking programs?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

I was able to see the watch now videos on Fox by going into the following: Options, Privacy and unchecking the 'Use Tracking Protection in Private Windows'

The Real Player solution listed in another post did not solve my problem. Now I can watch videos on Fox news again.

Hope this helps!

more options

Please help. Here's more info that I've learned. The Watch Now videos DO show up if Firefox is opened in Safe Mode. However, if I instead manually disable ALL the extensions and add-ons, close Firefox, and then re-open in normal mode with all disabled, the videos are NOT visible. Both the Hardware Acceleration and Tracking Protection have no effect on this and can be checked or unchecked. Does anyone know what other things that Safe Mode does or doesn't do that could cause this?

Modified by ckbckb

more options

ckbckb If this response doesn't help, Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new This will let us look at your system details. No Personal Information Is Collected.


Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default. After the above, Restart Firefox.

Poke around safe websites. Are there any problems?

more options

Thanks Fred. Yes, the problem goes away ONLY in Safe Mode. It does NOT go away with all add-ons manually disabled, use-hardware-acceleration turned off (or on), use-tracking-protection turned off (or on), and using the default theme. There's something else being done, or not done, in Safe Mode that makes the problem goes away.

Also, are you suggesting that I ask this same, identical question again and start a new thread? That doesn't sound efficient.

more options

Do you have any content blocking extensions (e.g. Adblock Plus, NoScript, Flash Block, Ghostery)?

Components that are part of extensions may still be active in normal mode despite the extension being disabled, so if you have such extensions then try to uninstall them.


Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Modified by cor-el