X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop Firefox from changing language settings?

Posted

FF 41.0.2 on a Ubuntu 14.04 machine

Two or three updates ago, Firefox started changing the spellchecker language settings. I'd set it to German and it'd remember at most for a few forum posts etc before switching back to English. Sometimes also the other way round though, it seems rather random.

Also, when trying to set it to the desired language, it often doesn't work the first time, I immediately need to call up the context menu a second time and select the desired language again.

FF 41.0.2 on a Ubuntu 14.04 machine Two or three updates ago, Firefox started changing the spellchecker language settings. I'd set it to German and it'd remember at most for a few forum posts etc before switching back to English. Sometimes also the other way round though, it seems rather random. Also, when trying to set it to the desired language, it often doesn't work the first time, I immediately need to call up the context menu a second time and select the desired language again.

Modified by Skinman

Additional System Details

Installed Plug-ins

  • Version: 5.41.0.0
  • The IcedTea-Web Plugin executes Java applets.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

guigs 1072 solutions 11697 answers

In your about:config page there are a list of entries, including spellchecker.dictionary

The first country code listed here should be the default. Try changing the order there.

In your about:config page there are a list of entries, including spellchecker.dictionary The first country code listed here should be the default. Try changing the order there.
cor-el
  • Top 10 Contributor
  • Moderator
17696 solutions 160119 answers

You can try to clear the Site Preferences to make Firefox forget a possible setting stored for this website. You can check the content-prefs.sqlite file with the SQLite Manager extension.

  • spellcheck.lang
You can try to clear the Site Preferences to make Firefox forget a possible setting stored for this website. You can check the content-prefs.sqlite file with the SQLite Manager extension. *spellcheck.lang

Question owner

guigs said

about:config page spellchecker.dictionary The first country code listed here should be the default. Try changing the order there.

I doubt this has a bearing on my issue. There's currently no list, just one entry, en-GB, and it says this was changed by me, the user, although I have no recollection of that.

I thought this might change each time I set the dictionary language via the context menu, but when I checked, *that* was set to German. At least for another web page. As I'm writing this, in another tab, the context menu dictionary is set to American English.

Which in turn I frankly fail to understand at all ;-) since I deleted all the dictionaries except the German one in an attempt to clear up the erratic behaviour.

''guigs [[#answer-801293|said]]'' <blockquote> about:config page spellchecker.dictionary The first country code listed here should be the default. Try changing the order there. </blockquote> I doubt this has a bearing on my issue. There's currently no list, just one entry, en-GB, and it says this was changed by me, the user, although I have no recollection of that. I thought this might change each time I set the dictionary language via the context menu, but when I checked, *that* was set to German. At least for another web page. As I'm writing this, in another tab, the context menu dictionary is set to American English. Which in turn I frankly fail to understand at all ;-) since I deleted all the dictionaries except the German one in an attempt to clear up the erratic behaviour.