X
Tap here to go to the mobile version of the site.

Support Forum

I can't get videos to play in Firefox until I close Firefox and reopen it. Super frustrating!

Posted

I keep Firefox open at almost all times and when I load a new page and try and play a video, whether on youtube, Facebook, or other source, it won't play. It just stays at the loading circle the whole time. The only time it works is when I completely exit out of Firefox and re-start it. This is quite frustrating for me because I often have multiple tabs open with other things I am working on that I don't want to close. I would appreciate any advice. Thank you

I keep Firefox open at almost all times and when I load a new page and try and play a video, whether on youtube, Facebook, or other source, it won't play. It just stays at the loading circle the whole time. The only time it works is when I completely exit out of Firefox and re-start it. This is quite frustrating for me because I often have multiple tabs open with other things I am working on that I don't want to close. I would appreciate any advice. Thank you

Chosen solution

These will close, then re-start Firefox, reloading the current session.

Restart {web link} "Restart" menu and button, with configurable shortcut key.


Restart Button {web link} Restart button for Firefox


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Simple plug-in that handles Citrix connection files
  • Provides information about the default web browser
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.0
  • 5.1.40416.0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

Chosen Solution

These will close, then re-start Firefox, reloading the current session.

Restart {web link} "Restart" menu and button, with configurable shortcut key.


Restart Button {web link} Restart button for Firefox


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

These will close, then re-start Firefox, reloading the current session. '''[https://addons.mozilla.org/en-US/firefox/addon/re-start/ Restart]''' {web link} "Restart" menu and button, with configurable shortcut key. '''[https://addons.mozilla.org/en-US/firefox/addon/restart-button/ Restart Button]''' {web link} Restart button for Firefox ------------ check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

Helpful Reply

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Thank you for your reply, FredMcD. I went down the list and the tip that worked was to erase my cache and cookies.

Question: if this was the problem all along, do you know why restarting Firefox also worked for me? I'm not really a computer person so I'm not sure how those would be related. Thanks!

Thank you for your reply, FredMcD. I went down the list and the tip that worked was to erase my cache and cookies. Question: if this was the problem all along, do you know why restarting Firefox also worked for me? I'm not really a computer person so I'm not sure how those would be related. Thanks!
FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

Can't really be sure. But as long as it works . . . .

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Can't really be sure. But as long as it works . . . . Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.