Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ZTE Open II - FfOS 1.3 - Email [bad-security] - Unable to establish a secure connection

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by WerWer

more options

Hi! I'm configuring some email accounts, using IMAP/SMTP, but I've some problems with certificates apparently. I've tried this solution https://support.mozilla.org/en-US/questions/1001848 using the dig command with no luck.

Email account: info@hovyu.com Mail server: mail.hovyu.com

dig mail.hovyu.com = 200.58.111.245 dig -x 200.58.111.245 = aprilia.dattaweb.com

Using : IMAP STARTLS 143 User: info@hovu.com Server: aprilia.dattaweb.com

SMTP STARTLS 587 User: info@hovu.com Server: aprilia.dattaweb.com

I'm still getting the same error. What could be the reason for the workaround not working for me? It's only for SSL security? Thanks!

All Replies (1)

more options

The "bad security" error is often due to a site using self-signed certificates. If this is the case, explicitly naming the mail host probably will not change anything. If the cause is a self-signed certificate, you could try to access the site with your browser and add an exception for the certificate (as described in the article you listed above). If that does not work, you have to manually add the certificate to your phone following the procedure described in the article you listed above (also shown here: http://www.pending.io/add-cacert-root-certificate-to-firefox-os/). I followed the path described there and was able to get my e-mail to work.