X
Tap here to go to the mobile version of the site.

Support Forum

Firefox v41 asking to Enable Add-ons Every Time I use Firefox

Posted

Using Windows 7 - since installing v41 every time I use Firefox it asks me enable every add-on rather than automatically loading them automatically - how can I prevent this from happening? I want them loading automatically like they were with v40.

Using Windows 7 - since installing v41 every time I use Firefox it asks me enable every add-on rather than automatically loading them automatically - how can I prevent this from happening? I want them loading automatically like they were with v40.

Chosen solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":


If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.

You can also check for problems with preferences.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.13
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nitro PDF plugin for Firefox and Chrome
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • Yahoo! activeX Plug-in Bridge
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Chosen Solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":


If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.

You can also check for problems with preferences.

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available. If this hasn't helped then also delete possible addons.json and addons.sqlite files. You can also check for problems with preferences. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences

Question owner

Thank you - Deleting the extensions.* files did the trick.

Thank you - Deleting the extensions.* files did the trick.
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Glad to help. Safe surfing.

Glad to help. Safe surfing.

Question owner

It happened again this morning - after starting Firefox a couple times (rather than the first time) - but at least I have some idea now of how to resolve.

It happened again this morning - after starting Firefox a couple times (rather than the first time) - but at least I have some idea now of how to resolve.
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

If you continue to have problems,

Refresh Firefox {web link} is a LAST RESORT ! !

Refresh Firefox - reset add-ons and settings

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.

If you continue to have problems, '''[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refresh Firefox]''' {web link} is a '''LAST RESORT ! !''' Refresh Firefox - reset add-ons and settings If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.