Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox showing these random characters in place for images?

  • 31 replies
  • 1 has this problem
  • 73 views
  • Last reply by Windmarble

more options

I have removed all add ins and extensions. Cleared browser cache and cookies and did the 'refresh' button on firefox.com

http://imgur.com/a/U7p5C

All Replies (11)

more options

Any difference in the response headers if you refresh the page and bypass the cache via Ctrl+F5?

more options

Creating a new profile had no effect.

more options

Ctrl+F5 had no effect

more options

Do you have any security software running on your Mac?

You can also check the connection settings in Firefox.

  • Firefox > Preferences > Advanced > Network : Connection > Settings

See "Firefox connection settings":

more options

There is no security software running and there is no proxy, firewall configurations.

more options

Does the site work normally in Safari or Chrome?

more options

Yes. Under safari and chrome Netflix and other sites show as normal. I deleted FF and reinstalled. Same issue.

more options

Chrome's developer tools look a bit different, but if you use Inspect Element on the Netflix page there is a tab similar to Firefox's Network tab where you should be able to see whether Chrome is accessing the custom font file on the same path and whether it is getting the Access-Control header back from the server that Firefox is not showing.

I still can't think of any other reasons for the difference.

more options

It should be noted that I jumped back several versions of Firefox. Trying version 40, 39 and 38. All have the same issue. I made a big jump to 25 and everything rendered properly.

more options

Problem exists from 31-41. But prior it doesn't

more options

Firefox Developer edition 43 works fine.

  1. 1
  2. 2