Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarked links for search engines not activating keyboard after updating to Marshmallow

  • 2 replies
  • 3 have this problem
  • 39 views
  • Last reply by jscher2000

more options

Subject pretty much says it all.

When using Firefox 41.0.2 on Android 6.0 (Nexus 6 device), if I've bookmarked a search engine -- say, https://www.google.com or https://www.duckduckgo.com -- and then load that page via the bookmark, the Google keyboard (just the system default keyboard) is not activated when I click in the search box. It just gives me the text selection tool instead, but there's no text to select or anything since it's just a blank search box.

If I manually type the exact same entry into the address bar -- for instance, https://www.duckduckgo.com -- and load the page that way, the keyboard activates just fine once I click in the search box. It's only when loading the page via a bookmark that it doesn't work. I've tried both secure and non-secure versions of the pages and get the same results.

This only started happening once I upgraded to Marshmallow. Everything worked as expected before this when using bookmarks. And everything still works fine if I use bookmarked search engines in Chrome; only Firefox seems to be affected in this way.

I'll attach a couple of annotated screenshots to help visualize the problem.

Thanks for any help!

Attached screenshots

All Replies (2)

more options

I would have replied earlier, but updating my phone took a really long time...

Yes, I can replicate this problem. In fact, it occurs with bookmarks for both DuckDuckGo, a form on our local rapid transit website for trip planning, and another site. It seems that any text form control is unable to summon a keyboard if opened from Bookmarks.

Same problem if I open those sites from Top Sites, History, or Recent Tabs. So basically from any part of the home screen.

As a workaround, using menu > Reload will allow the keyboard for the form fields on the pages I tried.

I'll search to see whether a bug has been filed.

more options

Yes, it is a known problem.

  • I haven't tested it, but Firefox 42 beta 8 is scheduled to have the fix if you want to try Firefox Beta in several days after it reaches the Play store (currently beta 6 is there)