Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lots of webpage navigation issues since updating to Firefox 41

  • 3 replies
  • 1 has this problem
  • 28 views
  • Last reply by FredMcD

more options

Ever since the last major update to Firefox a few weeks ago, I've been having issues when using buttons such as Home, End, Pg Up, Pg Down when scrolling through webpages.

If I press End, it should go to the bottom of the page, but it usually either scrolls down a small distance or does nothing at all. When I'm way down on a webpage, pressing Home should take you up to the top of the page. However, it only does this on a rare occasion. It usually either scrolls up further DOWN on the page, scrolls to just a bit lower than the top, or does nothing at all.

Page up and page down are similar as well. Pg down many times scrolls wayyyyyyy up or down and Pg up goes wayyyy up or down... or nothing at all.

Upon updating to FF 41.0.2, I was hoping the issue was fixed but alas, the issue remains and so I decided to post this. I HAVE tested on other browsers like Chrome and MS Edge and they utilize the buttons properly.

Any advice? Thanks.

Chosen solution

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Actually, I *think* I may have just found the problem. I have caret browsing on and have had it on for a few weeks for technical reasons. That's almost certainly interfering with webpage navigation. I realized the issue after going to safe mode. Thanks for the assistance!

Read this answer in context 👍 0

All Replies (3)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Chosen Solution

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Actually, I *think* I may have just found the problem. I have caret browsing on and have had it on for a few weeks for technical reasons. That's almost certainly interfering with webpage navigation. I realized the issue after going to safe mode. Thanks for the assistance!

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.