X
Tap here to go to the mobile version of the site.

Support Forum

Using Firefox 18.0. My add-ons have all disappeared.

Posted

My add-ons have all disappeared. Tools>add-ons>Get Add-ons they will not load. Just get a continuous ‘loading’. My extensions are empty. I only really remember having McAfee Site Advisor but I could have had more. I use it daily. Tried previous solutions from https://support.mozilla.org/en-US/questions/1058393. Site Advisor is not there in any folder. Thank you.

My add-ons have all disappeared. Tools>add-ons>Get Add-ons they will not load. Just get a continuous ‘loading’. My extensions are empty. I only really remember having McAfee Site Advisor but I could have had more. I use it daily. Tried previous solutions from https://support.mozilla.org/en-US/questions/1058393. Site Advisor is not there in any folder. Thank you.
Attached screenshots

Modified by Marvin28

Chosen solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 19.0 r0
  • Google Update
  • 5.1.40728.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.15
  • VLC media player Web Plugin
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • ActiveTouch General Plugin Container Version 105
  • GEPlugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 3.5.5f2
  • Cortona Netscape Browser Plug-In (6, 0, 0, 179)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17591 solutions 159130 answers

Chosen Solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available. If this hasn't helped then also delete the addons.json file.
philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23511 answers

hi Marvin28, sorry but firefox 18 is horribly outdated & insecure...

please start by updating firefox to the latest version (that's firefox 41.0.1 at the moment)!

hi Marvin28, sorry but firefox 18 is [https://www.mozilla.org/en-US/security/known-vulnerabilities/ horribly outdated & insecure]... please start by [[Update Firefox to the latest version|updating firefox to the latest version]] (that's firefox 41.0.1 at the moment)!
FredMcD
  • Top 10 Contributor
4274 solutions 59943 answers
Look on your desktop. Do you see a folder called; '''Old Firefox?''' '''https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile''' '''https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles'''

Question owner

Thank you all for the replies. Thank you cor-el I deleted 2 files you suggested extensions.json & extensions.sqlite but couldn't find extensions.ini. However went to extensions & they loaded in immediately. I think I have some baddies on my PC. Now Firefox says that Siteadvisor is incompatible. Also the REMOVE button is gone across from it.

Regarding updating – I have always liked the ability to turn off JavaScript & and disable all cookies. I did try it a few months but did not like the newer features, the look and the way you disable java. I may try the newest again if I can’t get Siteadvisor to work.

Thank you all for the replies. Thank you cor-el I deleted 2 files you suggested extensions.json & extensions.sqlite but couldn't find extensions.ini. However went to extensions & they loaded in immediately. I think I have some baddies on my PC. Now Firefox says that Siteadvisor is incompatible. Also the REMOVE button is gone across from it. Regarding updating – I have always liked the ability to turn off JavaScript & and disable all cookies. I did try it a few months but did not like the newer features, the look and the way you disable java. I may try the newest again if I can’t get Siteadvisor to work.
cor-el
  • Top 10 Contributor
  • Moderator
17591 solutions 159130 answers

Java and JavaScript are different languages. To avoid confusion, see:

The check boxes to enable/disable JavaScript and load images automatically have been removed from "Options > Content".

You can look at an extension like this:

Java and JavaScript are different languages. To avoid confusion, see: *http://kb.mozillazine.org/JavaScript_is_not_Java The check boxes to enable/disable JavaScript and load images automatically have been removed from "Options > Content". You can look at an extension like this: *QuickJava: https://addons.mozilla.org/firefox/addon/quickjava/