X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How can I stop firefox from asking to choose a default search engine?

Posted

Every now and then when I search for something in the search bar instead of searching what I typed in it opens the search options page in a new tab. It's kind of annoying. Any way to stop this?

Every now and then when I search for something in the search bar instead of searching what I typed in it opens the search options page in a new tab. It's kind of annoying. Any way to stop this?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • 2.3.0
  • 0.70.4
  • Version 5.41.2.0
  • Google Update
  • Happy Cloud Web Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • My.com Games Detector Plug-in
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • 5.1.40728.0
  • Unity Player 5.0.3f2
  • Plugin for Wacom tablets.

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

jscher2000
  • Top 10 Contributor
8953 solutions 73374 answers

Sounds like a problem I have with the search bar from time to time. Often when the panel drops down, the mouse pointer is over some part of it. If you move the mouse, Firefox interprets that as selecting what you want to happen when you press Enter. Bumping the mouse may be all it takes to trigger this feature, using a different search site or opening the settings page, depending on where the pointer is.

I don't know of any workaround for this.

Sounds like a problem I have with the search bar from time to time. Often when the panel drops down, the mouse pointer is over some part of it. If you move the mouse, Firefox interprets that as selecting what you want to happen when you press Enter. Bumping the mouse may be all it takes to trigger this feature, using a different search site or opening the settings page, depending on where the pointer is. I don't know of any workaround for this.