X
Tap here to go to the mobile version of the site.

Support Forum

Cannot get English subtitles on Netflix

Posted

Hard of hearing. Had English subtitles on for Netflix since I recently joined. As of today that box says off and it will not click on. Browser is Firefox. I am not too computer savy.

Hard of hearing. Had English subtitles on for Netflix since I recently joined. As of today that box says off and it will not click on. Browser is Firefox. I am not too computer savy.

Chosen solution

We are here to help.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


This is probably a good site to be aware of http://www.accessfirefox.org/Firefox_Accessibility_Extensions.php It is a semi official mozilla community run site. IIRC the site and many of its addons were caught out by Australis. That is probably one site we should reach out to in advance if for instance making anything less distinct smaller, or lower contrast.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Coupons, Inc. Coupon Printer 5.0.2.5
  • Google Update
  • Shockwave Flash 19.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

FredMcD
  • Top 10 Contributor
4270 solutions 59890 answers

Chosen Solution

We are here to help.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


This is probably a good site to be aware of http://www.accessfirefox.org/Firefox_Accessibility_Extensions.php It is a semi official mozilla community run site. IIRC the site and many of its addons were caught out by Australis. That is probably one site we should reach out to in advance if for instance making anything less distinct smaller, or lower contrast.

We are here to help. Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart. ---------------- This is probably a good site to be aware of http://www.accessfirefox.org/Firefox_Accessibility_Extensions.php It is a semi official mozilla community run site. IIRC the site and many of its addons were caught out by Australis. That is probably one site we should reach out to in advance if for instance making anything less distinct smaller, or lower contrast.