X
Tap here to go to the mobile version of the site.

Support Forum

Current Firefox not showing all Tab options under General in options like closing multiple tabs pic included

Posted

I am currently running the newest version of Firefox. When I open up options under general, in the Tabs section I am only showing 4 of the 6 options. I do not have check boxes for warn me when closing multiple tabs or warn me when opening multiple tabs might slow down Firefox. These used to be showing and I'm not sure why they aren't now. I am adding a screenshot showing how it looks under General in my options.

This is quite strange, I wouldn't have noticed anything except I had multiple tabs open today. When I clicked the red X in the corner to shut them all down, instead of asking me it just shuts whichever tab I have open one by one.

Thanks for your assistance.

I am currently running the newest version of Firefox. When I open up options under general, in the Tabs section I am only showing 4 of the 6 options. I do not have check boxes for warn me when closing multiple tabs or warn me when opening multiple tabs might slow down Firefox. These used to be showing and I'm not sure why they aren't now. I am adding a screenshot showing how it looks under General in my options. This is quite strange, I wouldn't have noticed anything except I had multiple tabs open today. When I clicked the red X in the corner to shut them all down, instead of asking me it just shuts whichever tab I have open one by one. Thanks for your assistance.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • Unity Player 5.0.3f2
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

On mine they are coded with hidden="true" (screenshot attached). I don't know whether I have something set that causes this or whether it's an intentional change.

(To open the Inspector on this page, press Ctrl+Shift+i and then scroll the top part to that area, click the button at the left of the inspector's top bar, then click near the checkboxes. You can force the boxes to show if you doubleclick where it says true and change it to false. For what it's worth....)

On mine they are coded with hidden="true" (screenshot attached). I don't know whether I have something set that causes this or whether it's an intentional change. (To open the Inspector on this page, press Ctrl+Shift+i and then scroll the top part to that area, click the button at the left of the inspector's top bar, then click near the checkboxes. You can force the boxes to show if you doubleclick where it says true and change it to false. For what it's worth....)
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Helpful Reply

By the way, you can modify these settings in another way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tabs and pause while the list is filtered

(3) "Warn me when closing multiple tabs" : If the browser.tabs.warnOnClose preference is bolded and "user set" to false, double-click it to restore the default value of true

(4) "Warn me when opening multiple tabs might slow down Firefox" : If the browser.tabs.warnOnOpen preference is bolded and "user set" to false, double-click it to restore the default value of true

By the way, you can modify these settings in another way: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''tabs''' and pause while the list is filtered (3) ''"Warn me when closing multiple tabs"'' : If the '''browser.tabs.warnOnClose''' preference is bolded and "user set" to false, double-click it to restore the default value of true (4) ''"Warn me when opening multiple tabs might slow down Firefox"'' : If the '''browser.tabs.warnOnOpen''' preference is bolded and "user set" to false, double-click it to restore the default value of true

Question owner

Thank you for responding.

First thing, when I opened about:config both were set to true anyway.

Second, I included a new screen shot. When I opened the control shift i, I don't have as many options as you do to scroll through under inspector. I am not showing the sub-menus you have, and the one I can scroll through doesn't list the check boxes yours does. It seems I only have two if I am doing it correctly.

Thank you for responding. First thing, when I opened about:config both were set to true anyway. Second, I included a new screen shot. When I opened the control shift i, I don't have as many options as you do to scroll through under inspector. I am not showing the sub-menus you have, and the one I can scroll through doesn't list the check boxes yours does. It seems I only have two if I am doing it correctly.
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

With the Inspector, you are part of the way there. The HTML code is laid out as a "tree" diagram. To get to the relevant part, scroll the page in the top half of the tab down to where you can see any of the tab checkboxes. Then in the top row of the Inspector, just to the lef tof the word Inspector, there's a button to select an element in the page by clicking. Click the button, then one of the tab options, and the Inspector should zoom down into the relevant part of the code.

With the Inspector, you are part of the way there. The HTML code is laid out as a "tree" diagram. To get to the relevant part, scroll the page in the top half of the tab down to where you can see any of the tab checkboxes. Then in the top row of the Inspector, just to the lef tof the word Inspector, there's a button to select an element in the page by clicking. Click the button, then one of the tab options, and the Inspector should zoom down into the relevant part of the code.
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

The warn items are hidden when the related prefs have the default value. They only show when you toggle the prefs on the about:config page. Note that this may require to close and restart Firefox.

  • "Warn me when closing multiple tabs" (browser.tabs.warnOnClose)
  • "Warn me when opening multiple tabs might slow down Firefox" (browser.tabs.warnOnOpen)

Edit:

  • bug 1063625 - Show the "Warn me when closing multiple tabs" and "Warn me when opening multiple tabs might slow down &brandShortName;" checkboxes only when needed
The warn items are hidden when the related prefs have the default value. They only show when you toggle the prefs on the <b>about:config</b> page. Note that this may require to close and restart Firefox. * "Warn me when closing multiple tabs" (browser.tabs.warnOnClose) * "Warn me when opening multiple tabs might slow down Firefox" (browser.tabs.warnOnOpen) ----- Edit: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1063625 bug 1063625] - Show the "Warn me when closing multiple tabs" and "Warn me when opening multiple tabs might slow down &brandShortName;" checkboxes only when needed

Modified by cor-el

Question owner

By using the about:config, once I toggled them both to false the check boxes returned to the General page. I also checked to warn me when closing multiple tabs. However, when I click the red X in the upper right corner the current tab is the only one that closes. Normally, I would get the warning about closing multiple tabs and then when I clicked okay all would close. How do I get to change the red X back to closing all tabs at once?

By using the about:config, once I toggled them both to false the check boxes returned to the General page. I also checked to warn me when closing multiple tabs. However, when I click the red X in the upper right corner the current tab is the only one that closes. Normally, I would get the warning about closing multiple tabs and then when I clicked okay all would close. How do I get to change the red X back to closing all tabs at once?

Question owner

Here's a new wrinkle. So last night I was able to show all 6 check boxes under the general section. When I woke up this morning, after having shut the computer down last night and went in to Firefox only 4 were showing again. The two had disappeared that came up last night. I am very confused now.

Here's a new wrinkle. So last night I was able to show all 6 check boxes under the general section. When I woke up this morning, after having shut the computer down last night and went in to Firefox only 4 were showing again. The two had disappeared that came up last night. I am very confused now.
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

If you place a checkmark in the boxes or otherwise reset the two involved prefs then you won't see these two items after a Firefox restart. They only stay there if the prefs aren't default.

If you do not keep changes after a restart or otherwise have problems with preferences, see:


See also:

  • browser.showQuitWarning
  • browser.warnOnQuit
  • browser.tabs.warnOnCloseOtherTabs
If you place a checkmark in the boxes or otherwise reset the two involved prefs then you won't see these two items after a Firefox restart. They only stay there if the prefs aren't default. If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved ---- See also: * browser.showQuitWarning * browser.warnOnQuit *browser.tabs.warnOnCloseOtherTabs

Question owner

Is this new, because it used to be there before? Also, why is the red X in the upper corner not closing all the windows at once?

Is this new, because it used to be there before? Also, why is the red X in the upper corner not closing all the windows at once?
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

The close X in the top right corner only closes the current window.

Use "3-bar" menu button > Exit (Power button) (Windows: File > Exit; Mac: Firefox > Quit Firefox; Linux: File > Quit) to close Firefox with all open windows at once if you are currently doing that by clicking the close X on the Firefox title bar.

The close X in the top right corner only closes the current window. Use "3-bar" menu button > Exit (Power button) (Windows: File > Exit; Mac: Firefox > Quit Firefox; Linux: File > Quit) to close Firefox with all open windows at once if you are currently doing that by clicking the close X on the Firefox title bar.

Question owner

But it used to close all the tabs. Did this change with the current update, and is there a way to reverse it?

But it used to close all the tabs. Did this change with the current update, and is there a way to reverse it?
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Clicking the close X on the title bar or in the top right corner if the title bar is hidden will only close the current window. When this is the only window then Firefox will try to close the application. In some cases the close X may not work properly or otherwise behave differently.

Clicking the close X on the title bar or in the top right corner if the title bar is hidden will only close the current window. When this is the only window then Firefox will try to close the application. In some cases the close X may not work properly or otherwise behave differently.