X
Tap here to go to the mobile version of the site.

Support Forum

how to change the order extensions load in

Posted

i have last-pass and zenmate as extensions when opening the browser, zenmate loads first and prevents last pass form loading properly how to change this load order

i have last-pass and zenmate as extensions when opening the browser, zenmate loads first and prevents last pass form loading properly how to change this load order

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • LastPass Plugin
  • Shockwave Flash 19.0 r0
  • Enables interaction with CDF content.

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • Adblock Edge 2.1.9.1-signed ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • LastPass 3.2.21 (support@lastpass.com)
  • Omnibar 0.7.28.20141004.1-signed (omnibar@ajitk.com)
  • StumbleUpon 4.21 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • ZenMate Security, Privacy & Unblock VPN 5.0.3 (firefox@zenmate.com)
  • Beyond Australis 1.3 (thefoxonlybetter@quicksaver) (Inactive)
  • Interclue 1.6.3.1-signed ({c33c5b47-69c8-45a4-a5e0-af85bbe628dd}) (Inactive)
  • Screengrab (fix version) 0.98.09c ({02450914-cdd9-410f-b1da-db004e18c671}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0042
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 1-10-2012
  • driverDate2:
  • driverVersion: 8.15.10.2622
  • driverVersion2:
  • failures: [u'[GFX1-]: OpenSharedResource failed for format 65']
  • indices: [0]
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 answers

You can check the extensions.ini file in the Firefox profile folder and try to change the order in that file.

You can use this button to go to the current Firefox profile folder:

You can also try to uninstall and reinstall Zenmate to see if that makes Zenmate install as the last extension.

You can check the extensions.ini file in the Firefox profile folder and try to change the order in that file. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox You can also try to uninstall and reinstall Zenmate to see if that makes Zenmate install as the last extension.

Question owner

When I looked in the .ini file I found with the Mozilla suggestion to put in the run box :

%APPDATA%\Mozilla\Firefox\Profiles

the .ini file I got was basically empty:

[General] StartWithLastProfile=1

[Profile0] Name=default IsRelative=1 Path=Profiles/alu878lg.default

I don't know what to do with this. Any helpful advice?

When I looked in the .ini file I found with the Mozilla suggestion to put in the run box : %APPDATA%\Mozilla\Firefox\Profiles the .ini file I got was basically empty: [General] StartWithLastProfile=1 [Profile0] Name=default IsRelative=1 Path=Profiles/alu878lg.default I don't know what to do with this. Any helpful advice?
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

cor-el said

You can check the extensions.ini file in the Firefox profile folder
''cor-el [[#answer-789224|said]]'' <blockquote> You can check the '''extensions.ini''' file in the Firefox '''profile folder''' </blockquote>
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 answers

So you need to look in the Profiles/alu878lg.default folder for the extensions.ini file.

So you need to look in the Profiles/alu878lg.default folder for the extensions.ini file.

Question owner

even with "show hidden files" checked i cant find a file named "extensions.ini" or folder "Profiles/alu878lg.default " -- why? what am i doing wrong?

even with "show hidden files" checked i cant find a file named "extensions.ini" or folder "Profiles/alu878lg.default " -- why? what am i doing wrong?

Question owner

oh, btw, thanks everybody

oh, btw, thanks everybody
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.'''
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 answers

You need to look for the profile folder folder in "%APPDATA%\Mozilla\Firefox\Profiles\

  • %APPDATA%\Mozilla\Firefox\Profiles\alu878lg.default
  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\
You need to look for the profile folder folder in "%APPDATA%\Mozilla\Firefox\Profiles\ *%APPDATA%\Mozilla\Firefox\Profiles\alu878lg.default *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\

Modified by cor-el

Question owner

C:\Users\Valued Customer\AppData\Roaming\Mozilla\Firefox\Profiles\alu878lg.default\extensions

support@lastpass.com (folder) {02450914-cdd9-410f-b1da-db004e18c671}.xpi {AE93811A-5C9A-4d34-8462-F7B864FC4696}.xpi {c33c5b47-69c8-45a4-a5e0-af85bbe628dd}.xpi {fe272bd1-5f76-4ea4-8501-a05d35d823fc}.xpi firefox@zenmate.com.xpi

this is what i found there, and zenmate still loads before lastpass how would i change this? (you're very helpful, ty)

C:\Users\Valued Customer\AppData\Roaming\Mozilla\Firefox\Profiles\alu878lg.default\extensions support@lastpass.com (folder) {02450914-cdd9-410f-b1da-db004e18c671}.xpi {AE93811A-5C9A-4d34-8462-F7B864FC4696}.xpi {c33c5b47-69c8-45a4-a5e0-af85bbe628dd}.xpi {fe272bd1-5f76-4ea4-8501-a05d35d823fc}.xpi firefox@zenmate.com.xpi this is what i found there, and zenmate still loads before lastpass how would i change this? (you're very helpful, ty)
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 answers

Try to set LastPass as the last entry in extensions.ini and possibly move Zenmate to the top (i.e. switch the two entries).

Try to set LastPass as the last entry in extensions.ini and possibly move Zenmate to the top (i.e. switch the two entries).

Question owner

thanks, tried it but it doesn't make a difference as zenmate still loads immediately. i've sent an email to zenmate to see if they have any ideas, as it works fine in Chrome, but i don't use that one. will let you know.

In the meantime, thanks for helping.

thanks, tried it but it doesn't make a difference as zenmate still loads immediately. i've sent an email to zenmate to see if they have any ideas, as it works fine in Chrome, but i don't use that one. will let you know. In the meantime, thanks for helping.
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 answers

You're welcome.

You can try to delete the compatibility.ini file to force Firefox to rebuild the cache in addition of making the change to the extensions.ini file.

Did Firefox make changes to the extensions.ini file after you edited the file?

You're welcome. You can try to delete the compatibility.ini file to force Firefox to rebuild the cache in addition of making the change to the extensions.ini file. Did Firefox make changes to the extensions.ini file after you edited the file?

Question owner

Hey. Firefox updated to v. 41.0.1 and issue solved. Thank you everyone.

Hey. Firefox updated to v. 41.0.1 and issue solved. Thank you everyone.