Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube website won't open with Firefox since I upgraded to Windows 10.

  • 8 replies
  • 1 has this problem
  • 27 views
  • Last reply by Phoxuponyou

more options

Every time I try to access Youtube the browser returns the following message: "Connection was reset". I didn't have this problem when I was still using Windows 7.

All Replies (8)

more options
more options

I tried the above, including disabling Windows Defender and still can't open Youtube. I changed browser to Microsoft Edge but couldn't youtube homepage. I managed to open www.youtube.com/videos

more options

Are you typing in the URL? The solution for https://support.mozilla.org/en-US/questions/1022991 suggests that using a Google search instead may work. The answer there also lists some other things you can try.

Modified by Phoxuponyou

more options

I have been able to get into the website by pulling down a URL from History which I had visited whilst still using Windows 7. I can then go anywhere else in the website except the home page. I have also used google search as suggested and been able to open Youtube videos and music....but NOT the homepage....

more options

My problem is similar. I'm using Win10. Just updated my Kaspersky because the previous version was not compatible with Win10. Now, every time I do a search for a website, I get the following message. It does it with EVERY search engine. It won't let me add exceptions unless I go into Options and manually enter the page, and how can I do that if I don't know the URL of the page I'm trying to find? HELP.

more options

I've called the big guys to help you. Good luck.

more options

starmanjb said

My problem is similar. I'm using Win10. Just updated my Kaspersky because the previous version was not compatible with Win10. Now, every time I do a search for a website, I get the following message. It does it with EVERY search engine. It won't let me add exceptions unless I go into Options and manually enter the page, and how can I do that if I don't know the URL of the page I'm trying to find? HELP.

This may be unrelated but not uncommon. To avoid derailing, I'll just quickly say this may be your security suite scanning secure traffic (the search sites use HTTPS, correct?) and causing a certificate issue.

What does it say under Technical Details? Can you view the certificate and see who it is for and who is the authority on it? If it points to Kaspersky, you'll need to find out how you can fix their certificate in Firefox - or just disable the secure connection scanning and browser monitoring components in Kaspersky.

more options

Regarding the original issue; since this issue exists on two separate browsers and if the above articles did not help, I'm starting to think it might be a HOSTS file change or antivirus interference (global, "root level").

The suggestions in http://kb.mozillazine.org/Error_loading_any_website#Error_loading_some_websites are worth going through. They go in-depth, and HOSTS for example is mentioned there, whereas it is not in the previous articles.

It's easy to check the HOSTS file. Find it at the location indicated in https://en.wikipedia.org/wiki/Hosts_%28file%29#Location_in_the_file_system and see if "youtube" is mentioned. If you see an entry with youtube, remove the entry or comment it out.

Here is a tutorial for editing HOSTS in Win10: https://www.petri.com/easily-edit-hosts-file-windows-10.