X
Tap here to go to the mobile version of the site.

Support Forum

Add-on Installs

Posted

I recently got a new computer set up. I set up a Sync account, to get all of my info over properly. Everything seemed to install fine, no problem. But my add-ons are acting funny. I can open Firefox a few times, no issue. All of my add-ons are active, in their proper places on my toolbars, everything. Then I open it, I go to look at my add-ons, and it tells me I have no extensions (but I still see those that I have shown on my toolbars (such as the buttons for a download manager, ad-block, session manager, personas, etc...) I close firefox, reopen it, and I have a dozen "install add-on" tabs pop up asking me if I want to install add-ons that I did have, until that moment, already installed. I de-selected the add-on sync feature, and thought everything was fine, but it did it again a good day after I had deselected that sync option, so not sure what it's doing. TL:DR- Firefox keeps swearing I don't have add-ons, even when I see them on my screen (just not in extensions tab), and restarting Firefox asks me to reinstall all add-ons I already had.

I recently got a new computer set up. I set up a Sync account, to get all of my info over properly. Everything seemed to install fine, no problem. But my add-ons are acting funny. I can open Firefox a few times, no issue. All of my add-ons are active, in their proper places on my toolbars, everything. Then I open it, I go to look at my add-ons, and it tells me I have no extensions (but I still see those that I have shown on my toolbars (such as the buttons for a download manager, ad-block, session manager, personas, etc...) I close firefox, reopen it, and I have a dozen "install add-on" tabs pop up asking me if I want to install add-ons that I did have, until that moment, already installed. I de-selected the add-on sync feature, and thought everything was fine, but it did it again a good day after I had deselected that sync option, so not sure what it's doing. TL:DR- Firefox keeps swearing I don't have add-ons, even when I see them on my screen (just not in extensions tab), and restarting Firefox asks me to reinstall all add-ons I already had.

Additional System Details

Installed Plug-ins

  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • iTunes Detector Plug-in

Application

  • Firefox 41.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
  • Support URL: https://support.mozilla.org/1/firefox/41.0.1/WINNT/en-US/

Extensions

  • 1-Click YouTube Video Downloader 2.4.0.1-signed (YoutubeDownloader@PeterOlayev.com)
  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Classic Theme Restorer 1.4.0 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Download Manager (S3) 3.11.1-signed (s3download@statusbar)
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Image Toolbar 0.6.16.1-signed ({A4732521-77D9-447E-A557-B279AC923F06})
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • New Tab Toolbar Button Updated Version 1.2.1-signed ({42975993-6fa0-46f5-a45f-706915f18ebc})
  • New Tab Tools 52 (newtabtools@darktrojan.net)
  • Personas Plus 1.7.3.1-signed (personas@christopher.beard)
  • Session Manager 0.8.1.7 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Tab Mix Plus 0.4.1.9 ({dc572301-7619-498c-a57d-39143191b318})
  • Video DownloadHelper 5.4.1 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon(TM) R7 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x1313
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 78911462
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 8-16-2014
  • driverDate2:
  • driverVersion: 13.352.1019.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon(TM) R7 Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Phoxuponyou 51 solutions 517 answers

Here's an older workaround if it's Sync: https://bugzilla.mozilla.org/show_bug.cgi?id=1099973#c5.

You can also see mention of trouble with antivirus software. Which one are you using and do you have browser protection components turned on?

Here's an older workaround if it's Sync: https://bugzilla.mozilla.org/show_bug.cgi?id=1099973#c5. You can also see mention of trouble with antivirus software. Which one are you using and do you have browser protection components turned on?

Question owner

For some reason, I was never alerted I got a reply. When I started having this issue, it was before I had reinstalled my antivirus (I know, bad me) and I use Avast Internet Security. This is also a brand new custom built computer, (runing 7 Pro) so there was nothing installed before I started putting programs onto it. I had even turned off sync when I tried to fix this add on issue. It keeps doing it to me. I'll have all my add ons, everything going fine. I look at the addons tab, it says there are none installed, even though everything exists. Everything works, I just can't use that addon tab in my tools to adjust any. They don't try to reinstall unless I try to install any addon. Then once I install and restart Firefox, every single addon wants to reinstall.

I even deleted everything Firefox related from this computer and reinstalled Firefox, and it does it again, so I'm wondering if there could be another sync glitch that's causing it.

For some reason, I was never alerted I got a reply. When I started having this issue, it was before I had reinstalled my antivirus (I know, bad me) and I use Avast Internet Security. This is also a brand new custom built computer, (runing 7 Pro) so there was nothing installed before I started putting programs onto it. I had even turned off sync when I tried to fix this add on issue. It keeps doing it to me. I'll have all my add ons, everything going fine. I look at the addons tab, it says there are none installed, even though everything exists. Everything works, I just can't use that addon tab in my tools to adjust any. They don't try to reinstall unless I try to install any addon. Then once I install and restart Firefox, every single addon wants to reinstall. I even deleted everything Firefox related from this computer and reinstalled Firefox, and it does it again, so I'm wondering if there could be another sync glitch that's causing it.
Phoxuponyou 51 solutions 517 answers

Helpful Reply

If you didn't have protection on at the time, better run malware scans to be sure you're working off clean materials: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-get-rid-of-malware. One scanner is sometimes not enough, mind.

When you say deleted everything Firefox related, does that apply to profiles too? As in AppData\Roaming\Mozilla. That's where the problem will be, I reckon, and if it did not get deleted, the new installation will inherit old data. Sync can also bring back old, possibly corrupt data - I recommend changing your password to scramble old data (it will become unusable) if you use Sync. You did mention you are trying to carry over an old profile, and I think that might be the root cause here - it's deprecated along the way and it's time for a new one.

Speaking of, the next troubleshooting step you can try is turning and keeping Sync off and making a whole new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles#w_creating-a-profile. Do not import anything, install fresh add-ons.

If the fresh installs stick, it's probably an issue with profile files like extensions.json that keep tabs on your add-ons (Extensions in this case).

Is the issue still there in 42.x?

If you didn't have protection on at the time, better run malware scans to be sure you're working off clean materials: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-get-rid-of-malware. One scanner is sometimes not enough, mind. When you say deleted everything Firefox related, does that apply to profiles too? As in AppData\Roaming\Mozilla. That's where the problem will be, I reckon, and if it did not get deleted, the new installation will inherit old data. Sync can also bring back old, possibly corrupt data - I recommend changing your password to scramble old data (it will become unusable) if you use Sync. You did mention you are trying to carry over an old profile, and I think that might be the root cause here - it's deprecated along the way and it's time for a new one. Speaking of, the next troubleshooting step you can try is turning and keeping Sync off and making a whole new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles#w_creating-a-profile. Do not import anything, install fresh add-ons. If the fresh installs stick, it's probably an issue with profile files like extensions.json that keep tabs on your add-ons (Extensions in this case). Is the issue still there in 42.x?
FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

Helpful Reply

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons
cor-el
  • Top 10 Contributor
  • Moderator
17480 solutions 157964 answers

You can also check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can also check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences