Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop it from populating old website searches, autofill etc??

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

I tried changing my privacy settings, clearing my history, and refreshing my firefox. I also tried deleting firefox, and all its files, and then reinstalling. After all this, all my "searches" and autofill information continues to populate in the web search bar and within website search bars. I am using a Mac

All Replies (2)

more options

It can be removed in the suggestion bar settings with these instructions:

  1. Open a new window and put this in the url bar about:preferences#privacy
  2. Under "Location bar" click on "Change preferences for search engine suggestions…"

or

  1. Go directly to about:preferences#search and uncheck "Provide Search Suggestions"

I hope this helps.

more options

You can remove already stored form data via "History > Clear Recent history".