Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't open new (empty) tab

  • 12 replies
  • 4 have this problem
  • 1636 views
  • Last reply by Phoxuponyou

more options

When I want to open a new tab in Firefox (OS. windows 10) it won't let me. Clicking on the '+' sign or using ctrl+t does nothing. When I want a new tab, I've got to open a random link in a new tab and then use that one. Very annoying.

I've tried disableing all add-ons and extensions, did not work. I've tried starting up Firefox in safe-mode, did not work. I've tried reïnstalling Firefox, did not work.

Anybody with a suggestion?

Chosen solution

Great, glad to help! At least the functionality is there.

Good point about the Windos jumplist - I tend to forget it's there as I never got used to using them.

Shortcuts and hotkeys are usually assigned by programs themselves by default, so it's probably not something you actively did yourself.

The [+] not working even in Safe Mode got me thinking of hooks and overlays and other ways that antivirus suites (and other programs) can hijack input. The only way to prevent this is by going into Windows Safe Mode - this disables (should and so far always has disabled) all extra functionality and programs, so whatever you run in that mode should run unobstructed. The next step in my mind would be to try Ctrl+T and the [+] in Windows Safe Mode.

Other than that, I'm down to suggesting you run anti-malware checks with multiple scanners (this article, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-get-rid-of-malware, lists all I would suggest and then some) and disabling/uninstalling programs 1-by-1 until Ctrl+T works.

The former is in case this behaviour is caused by malicious software.

The latter is in case this is accidental behaviour by ordinary software. I would bank on the latter myself - here is an example https://discussion.evernote.com/topic/44437-skitch-global-hotkey-conflicts-list-of-applications-affected/ - but pride and prejudice should never rule out a good barrage of anti-malware checks.

Read this answer in context 👍 1

All Replies (12)

more options

All I can think of is antivirus. What antivirus suite do you use and do you have browsing protection like "anti-banner" or "anti-scam" or "advisor" stuff turned on?

I couldn't find anything on searches but add-on trouble.

more options

New Tab Override (browser.newtab.url replacement) https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/

With Firefox 41 (and higher), it's no longer possible to customize the page shown in a new tab via changing the preference browser.newtab.url in about.config. Because of the fact that hijackers abused the preference in the past, Mozilla decided to remove it (see bug 1118285). Fortunately, by removing it, Mozilla also introduced a new API to bring this functionality back to life as an add-on. This add-on allows the user to choose a certain page in a new tab.

more options

This just started after the update? And the problem persists in Firefox's Safe Mode? Two things come to mind with this kind of UI breakage:

(1) Possibly one of your plugins isn't fully compatible with Firefox 41 (Safe Mode doesn't disable plugins)

(2) Possibly one or more program files became corrupted in the update process

For #1, you can review your plugins and minimize what is running on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate". Then test in a new window (Ctrl+n) to see whether it made any difference.

For #2, I suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 41.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in (A). It should automatically connect to your existing settings.

Does that repair it?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Thank you all for your suggestions. I've tried them all but nothing works..

But thanks anyway! I'm going to continue searching.

more options

Even though you've tried Safe Mode (i.e. all add-ons disabled), can you try this solution: https://uglyduckblog.wordpress.com/2013/10/02/solved-new-tab-is-not-opening-in-firefox-24/ ? This is the closest thing I've found googling around.

Copying the solution here for posteriority: "Solution to the Firefox new tab not opening problem

Setting browser.newtab.preload to false in about:config fixed it.

Type about:config into your browser, and click 'I’ll be careful, I promise.'

Then type [or copy/paste] browser.newtab.preload into the long search bar that appears.

Then set the Value to false, restart browser and it should be working fine just like it did for me."

Modified by Phoxuponyou

more options

If I think if anything new, I'll let you know.

Meanwhile, a few other workarounds that might be easier than a random link, unless these are broken, too:

  • Alt+Enter: if you type an address in the address bar or a search in the search bar, Alt+Enter directs it to a new tab
  • Ctrl+click bookmark: If you have a bookmark for the page you want in a new tab, you can Ctrl+click it to direct it to open in a new tab
more options

Phoxuponyou, that also didn't do the trick. It's really weird..

jscher2000, thank you for the workarounds! It sure is better than nothing!

more options

Alright; don't forget to reverse the change, now!

Since Ctrl+click works (and Alt+Enter works), it's not the keyboard either (stuck or obstructed key or signal for example).

I am still thinking something is hijacking the command (using it as a global hotkey in anything? tried in Windows Safe Mode so antivirus doesn't interfere?). The "global hotkey" aspect got me thinking that maybe the shortcut got messed up - add-ons (even disabled/uninstalled ones can leave bad settings), corruption, malware, etc.

You could try checking and reassigning the shortcut using https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/. Once you install, you don't need to restart. There will be a small icon next to the "menu burger" that looks like three keys (two small keys on top of a longer one). Click that and search for "New Tab".

If the shortcut is wrong, great! Just reassign to Ctrl+T and test (restart if it doesn't take immediately).

If the shortcut is correct, reassign to another combination (the plugin will warn you if there is a conflict, handy!), see if that combo works, and then revert back to Ctrl+T and see if that works. If Ctrl+T STILL won't work, then it's a hijacking and we need to go on the hunt again.

PS. Check the File menu: press Alt and then the down arrow. What's it say about the new tab option (I see Ctrl+T as the shortcut) and can you make a new tab this way?

Modified by Phoxuponyou

more options

Phoxuponyou, thank you for the suggestion! I assigned new tab to another CTRL - combo and it worked, switched it back to CTRL+T and still didn't work, so, as you said, it must be a hijacking of some sort. I myself haven't set any hotkey to a ctrl-t combo.

PS. I can open a new tab when I right click the firefox icon and click 'new tab'

more options

Chosen Solution

Great, glad to help! At least the functionality is there.

Good point about the Windos jumplist - I tend to forget it's there as I never got used to using them.

Shortcuts and hotkeys are usually assigned by programs themselves by default, so it's probably not something you actively did yourself.

The [+] not working even in Safe Mode got me thinking of hooks and overlays and other ways that antivirus suites (and other programs) can hijack input. The only way to prevent this is by going into Windows Safe Mode - this disables (should and so far always has disabled) all extra functionality and programs, so whatever you run in that mode should run unobstructed. The next step in my mind would be to try Ctrl+T and the [+] in Windows Safe Mode.

Other than that, I'm down to suggesting you run anti-malware checks with multiple scanners (this article, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-get-rid-of-malware, lists all I would suggest and then some) and disabling/uninstalling programs 1-by-1 until Ctrl+T works.

The former is in case this behaviour is caused by malicious software.

The latter is in case this is accidental behaviour by ordinary software. I would bank on the latter myself - here is an example https://discussion.evernote.com/topic/44437-skitch-global-hotkey-conflicts-list-of-applications-affected/ - but pride and prejudice should never rule out a good barrage of anti-malware checks.

more options

Thanks a bunch!! I finally found the culprit. It was some sort of malware-type software named ORBTR that, after some searching, installs itself when installing software like utorrent..

After deleting all ORBTR associated files the problem with Firefox was gone.

Thanks again for all the help from you guys!

more options

Super! Thanks for reporting back, helps a lot going forward.