X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop Firefox from lagging and freezing on YouTube videos?

Posted

I'm having a new issue (it started about a week or two ago) where Firefox runs fine until I try to play YouTube videos. Then Firefox lags for about 1 to 10 seconds. The bar at the top will flash "Not Responding" before going back to normal. This happens numerous times.

I have tried shutting down all other applications, "refreshing" Firefox, turning off Privacy Badger and AdBlock Pro, turning off Shockwave Flash's "protected mode, and even unchecked Firefox's "Use hardware acceleration." So far, none of these fixes work. I even even went so far as to try a HTML 5 add-on for Firefox. So far, nothing has stopped this lagging.

I've Googled and saw a lot of other people with this issue (so it's not just me), but I have yet to find a fix. Can anyone help?

I'm having a new issue (it started about a week or two ago) where Firefox runs fine until I try to play YouTube videos. Then Firefox lags for about 1 to 10 seconds. The bar at the top will flash "Not Responding" before going back to normal. This happens numerous times. I have tried shutting down all other applications, "refreshing" Firefox, turning off Privacy Badger and AdBlock Pro, turning off Shockwave Flash's "protected mode, and even unchecked Firefox's "Use hardware acceleration." So far, none of these fixes work. I even even went so far as to try a HTML 5 add-on for Firefox. So far, nothing has stopped this lagging. I've Googled and saw a lot of other people with this issue (so it's not just me), but I have yet to find a fix. Can anyone help?

Additional System Details

Installed Plug-ins

  • Wacom Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • Plugin for Wacom tablets.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? ----------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Just restarting Firefox in "Safe Mode" takes care of the problem from the short time I tested it, but lagged right away when I reopened Firefox normally. Certainly this can't mean I can only watch YouTube in "Safe Mode." can it?

''FredMcD [[#answer-783551|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?</blockquote> Just restarting Firefox in "Safe Mode" takes care of the problem from the short time I tested it, but lagged right away when I reopened Firefox normally. Certainly this can't mean I can only watch YouTube in "Safe Mode." can it?
BlueDuty 0 solutions 1 answers

Hello this is what i would recommend for you my friend, follow my steps and i believe it will solve 99% of issues you have also secure and speed up your computer.

1. Download MalwareBytes Free version 2. Do a full scan of your Device 3. Clear any issues MalwareBytes finds 4. Restart your Device 5. Check if all issues are fixed if not let me know ill fix this for you.

Hello this is what i would recommend for you my friend, follow my steps and i believe it will solve 99% of issues you have also secure and speed up your computer. 1. Download [https://www.malwarebytes.org/ MalwareBytes] Free version 2. Do a full scan of your Device 3. Clear any issues MalwareBytes finds 4. Restart your Device 5. Check if all issues are fixed if not let me know ill fix this for you.
FredMcD
  • Top 10 Contributor
4246 solutions 59401 answers

Helpful Reply

Totally_Tammy said

Just restarting Firefox in "Safe Mode" takes care of the problem

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

''Totally_Tammy [[#answer-783558|said]]'' <blockquote> Just restarting Firefox in "Safe Mode" takes care of the problem </blockquote> It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Question owner

FredMcD said

Totally_Tammy said
Just restarting Firefox in "Safe Mode" takes care of the problem

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

This sort of worked and that's good enough for me! I have two add-ons that seem to be a problem. I run both Privacy Badger and AdBlock Plus.

If I run them both I have hang-ups, if I run only one while logged into YouTube the video plays while the rest of the page is slower to load, but if I run only one WITHOUT logging into YouTube everything runs fine.

Seems like the ad blocking software doesn't like it when I'm running more than one or if I'm logged into my Google account when viewing videos.

''FredMcD [[#answer-783668|said]]'' <blockquote> ''Totally_Tammy [[#answer-783558|said]]'' <blockquote> Just restarting Firefox in "Safe Mode" takes care of the problem </blockquote> It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective. </blockquote> This sort of worked and that's good enough for me! I have two add-ons that seem to be a problem. I run both Privacy Badger and AdBlock Plus. If I run them both I have hang-ups, if I run only one while logged into YouTube the video plays while the rest of the page is slower to load, but if I run only one WITHOUT logging into YouTube everything runs fine. Seems like the ad blocking software doesn't like it when I'm running more than one or if I'm logged into my Google account when viewing videos.
lamiejang 1 solutions 6 answers

Helpful Reply

I had this exactly problem, for whatever reason the cause is the list populated in the sidebar of Youtube. It really doesn't appear that heavy duty - it's just a UL list with some thumbnails - but it causes me several delays of around 5 seconds every time a page is loaded. (I am subbed to around 250 channels). I tracked the lag using the Performance tab under F12 and could see 3 pauses block-waiting on Graphics.

The workaround I'm using is to install the addon "Stylish" to allow custom CSS, then use a rule to hide the long Subscriptions list from the sidebar to avoid the layout engine bothering rendering it.

This is my rule to use in Stylish:

@-moz-document domain("youtube.com") {

#guide-channels{
  display:none !important;
}

}

I now have no noticeable delay on any YT page.

I had this exactly problem, for whatever reason the cause is the list populated in the sidebar of Youtube. It really doesn't appear that heavy duty - it's just a UL list with some thumbnails - but it causes me several delays of around 5 seconds every time a page is loaded. (I am subbed to around 250 channels). I tracked the lag using the Performance tab under F12 and could see 3 pauses block-waiting on Graphics. The workaround I'm using is to install the addon "Stylish" to allow custom CSS, then use a rule to hide the long Subscriptions list from the sidebar to avoid the layout engine bothering rendering it. This is my rule to use in Stylish: @-moz-document domain("youtube.com") { #guide-channels{ display:none !important; } } I now have no noticeable delay on any YT page.