X
Tap here to go to the mobile version of the site.

Support Forum

Browser lockup loading Youtube Subscriptions page - graphics paint?

Posted

I'm having problems loading Youtube in Firefox, both the subscription page and any individual video will freeze for a few seconds whilst everything is loaded in and I won't be able to scroll or change tab, CPU core max out, fan sometimes comes on. There's basically no delay browsing it in Chrome.

Attached a "Performance snapshot" of the page loading and it seems to stick in 3 places performing "Graphics/paint". These phases seem negligible browsing a page with equivalent number of images (eg. BBC news site).

So I'm wondering if it's due to the website just having an overly complex layout, is a known problem, or if there is something I can do to reduce the load?

Thanks, (Installed Win 10 from scratch last week, all updated, and no extensions to speak of. i5-3230m, gt-650m 2gb/intel HD, SSD)

I'm having problems loading Youtube in Firefox, both the subscription page and any individual video will freeze for a few seconds whilst everything is loaded in and I won't be able to scroll or change tab, CPU core max out, fan sometimes comes on. There's basically no delay browsing it in Chrome. Attached a "Performance snapshot" of the page loading and it seems to stick in 3 places performing "Graphics/paint". These phases seem negligible browsing a page with equivalent number of images (eg. BBC news site). So I'm wondering if it's due to the website just having an overly complex layout, is a known problem, or if there is something I can do to reduce the load? Thanks, (Installed Win 10 from scratch last week, all updated, and no extensions to speak of. i5-3230m, gt-650m 2gb/intel HD, SSD)
Attached screenshots

Chosen solution

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

From Mozilla help files;

Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

Read this answer in context 0

Additional System Details

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • Classic Theme Restorer 1.3.9 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Flashblock 1.5.18.1-signed ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • New Tab Tools 51 (newtabtools@darktrojan.net)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2: NVIDIA GeForce GT 650M
  • adapterDeviceID: 0x0166
  • adapterDeviceID2: 0x0fd1
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 05781028
  • adapterSubsysID2: 05781028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-10-2015
  • driverDate2: 7-22-2015
  • driverVersion: 10.18.10.4252
  • driverVersion2: 10.18.13.5362
  • failures: [u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,16840) Code: 0x80070057', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,16840) Code: 0x80070057', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,16840) Code: 0x80070057', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,16840) Code: 0x80070057', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,16840) Code: 0x80070057', u'[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,16840) Code: 0x80070057']
  • indices: [0, 16, 17, 18, 19, 20]
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
FredMcD
  • Top 10 Contributor
4248 solutions 59432 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? -------------- '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Question owner

Thanks I tried those, but neither seemed to have an impact (other than initially having to cache the Youtube assets again).

I actually have "solved" this however by unchecking "Use hardware acceleration when available" in options, then restarting.

Don't know why this would make Youtube so unresponsive however. It's as if Firefox is waiting for the Graphics card to become available before processing further events? Either my GFX card is dodgy or there's a bug somewhere.

Additionally I installed an addon with a Javascript on/off toggle button, and having JS disabled also instantly removes the graphics delay and lockup.

Thanks I tried those, but neither seemed to have an impact (other than initially having to cache the Youtube assets again). I actually have "solved" this however by unchecking "Use hardware acceleration when available" in options, then restarting. Don't know why this would make Youtube so unresponsive however. It's as if Firefox is waiting for the Graphics card to become available before processing further events? Either my GFX card is dodgy or there's a bug somewhere. Additionally I installed an addon with a Javascript on/off toggle button, and having JS disabled also instantly removes the graphics delay and lockup.
FredMcD
  • Top 10 Contributor
4248 solutions 59432 answers

Chosen Solution

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

From Mozilla help files;

Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know. From Mozilla help files; Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.