Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webcam is not working, only black image

  • 4 replies
  • 1 has this problem
  • 17 views
  • Last reply by cor-el

more options

Hi I have a problem with my new bought hp pavillion 10-k000ng with windows 8 1. The camera is working just fine outside firefox, but using it for firefox hello is not working. No error message is shown, it only goes to a black image. I also do not get the media symbol beside the url field. I also tried other webpages for testing the webcam and on non it is working. Therefor, I think it must be a problem of firefox and not hello. Thank you very much for your help! cheers Evchen

All Replies (4)

more options

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Issues have been previously linked to the McAfee Site Advisor extension. Try to disable it and see if the problem persists.

http://service.mcafee.com/faqdocument.aspx?id=TS100162 How to uninstall SiteAdvisor

To disable it: Type "about:addons" in the Location bar Find the extension and click on its "Disable" button

more options

Thanks your your answer, but it is still not working.

more options

Can you post a public link to the camera?


You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.


1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.


https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

more options

You can check the Web Console (Firefox/Tools > Web Developer) for error messages.