X
Tap here to go to the mobile version of the site.

Support Forum

Firefox hangs on Youtube and other websites that use HTML5

Posted

As of early this afternoon (Tuesday, September 15th, 2015) my Firefox browser has been acting odd and hanging over and over on sites that mainly use HTML5, such as Youtube. As far as I can tell, no-one else has encountered this specific behavior before using the latest version of Firefox. The hangs persist even in safe mode, and I am certain that my addons are not causing the issue. I have tried refreshing Firefox, updating my graphics drivers, and even updating Flash, but nothing is changing.

As of early this afternoon (Tuesday, September 15th, 2015) my Firefox browser has been acting odd and hanging over and over on sites that mainly use HTML5, such as Youtube. As far as I can tell, no-one else has encountered this specific behavior before using the latest version of Firefox. The hangs persist even in safe mode, and I am certain that my addons are not causing the issue. I have tried refreshing Firefox, updating my graphics drivers, and even updating Flash, but nothing is changing.

Additional System Details

Installed Plug-ins

  • Creative Cloud Desktop Plugin.v_2_0_0_0
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • Plugin for Wacom tablets.

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • Bitdefender Wallet 2.0 (bdwteff@bitdefender.com)
  • New XKit 7.7.0 (@new-xkit)
  • Stylish 2.0.2.1-signed ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • uBlock 0.9.1.0.1-signed ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42})
  • YouTube mp3 1.0.9.1-signed (info@youtube-mp3.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 21b7103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-17-2015
  • driverDate2:
  • driverVersion: 10.18.15.4256
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

If you open the Windows 10 Task Manager (probably Ctrl+Shift+Esc still works) can you see an unusual load on the CPU when this happens?

Did you recently install any Windows updates?

If you open the Windows 10 Task Manager (probably Ctrl+Shift+Esc still works) can you see an unusual load on the CPU when this happens? Did you recently install any Windows updates?
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157294 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

jscher2000 said

If you open the Windows 10 Task Manager (probably Ctrl+Shift+Esc still works) can you see an unusual load on the CPU when this happens? Did you recently install any Windows updates?

Looks like it does add a big load to the CPU. It jumps from 35% to around 55% whenever it happens.

As for updates, I only updated my graphics drivers using an Intel updater yesterday.

''jscher2000 [[#answer-781575|said]]'' <blockquote> If you open the Windows 10 Task Manager (probably Ctrl+Shift+Esc still works) can you see an unusual load on the CPU when this happens? Did you recently install any Windows updates? </blockquote> Looks like it does add a big load to the CPU. It jumps from 35% to around 55% whenever it happens. As for updates, I only updated my graphics drivers using an Intel updater yesterday.
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

VictorMarrero said

As for updates, I only updated my graphics drivers using an Intel updater yesterday.

There often are compatibility glitches with new drivers, which are used to accelerate video decoding. But Safe Mode doesn't affect it, or does it make CPU usage worse?

''VictorMarrero [[#answer-781814|said]]'' <blockquote>As for updates, I only updated my graphics drivers using an Intel updater yesterday.</blockquote> There often are compatibility glitches with new drivers, which are used to accelerate video decoding. But Safe Mode doesn't affect it, or does it make CPU usage worse?

Question owner

jscher2000 said

VictorMarrero said
As for updates, I only updated my graphics drivers using an Intel updater yesterday.

There often are compatibility glitches with new drivers, which are used to accelerate video decoding. But Safe Mode doesn't affect it, or does it make CPU usage worse?

Safe Mode still makes it hang at around the same percentages.

''jscher2000 [[#answer-781817|said]]'' <blockquote> ''VictorMarrero [[#answer-781814|said]]'' <blockquote>As for updates, I only updated my graphics drivers using an Intel updater yesterday.</blockquote> There often are compatibility glitches with new drivers, which are used to accelerate video decoding. But Safe Mode doesn't affect it, or does it make CPU usage worse? </blockquote> Safe Mode still makes it hang at around the same percentages.
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

I don't know whether anything here will help, you might have seen these already:

I don't know whether anything here will help, you might have seen these already: * [[Firefox uses too many CPU resources - How to fix]] * [[Firefox hangs or is not responding - How to fix]]

Question owner

jscher2000 said

I don't know whether anything here will help, you might have seen these already:

I've already read through the Hangs help page, but after reading the CPU help page, i disabled all of my plugins and got a performance boost on the Youtube homepage. However, viewing videos still causes 30 second hangs which raise CPU usage to 55% as before..

''jscher2000 [[#answer-781858|said]]'' <blockquote> I don't know whether anything here will help, you might have seen these already: * [[Firefox uses too many CPU resources - How to fix]] * [[Firefox hangs or is not responding - How to fix]] </blockquote> I've already read through the Hangs help page, but after reading the CPU help page, i disabled all of my plugins and got a performance boost on the Youtube homepage. However, viewing videos still causes 30 second hangs which raise CPU usage to 55% as before..

Question owner

cor-el said

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Unfortunately, the issue persists even in Windows Safe Mode.

''cor-el [[#answer-781748|said]]'' <blockquote> Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 </blockquote> Unfortunately, the issue persists even in Windows Safe Mode.
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157294 answers

You can try to disable the HTML5 media player and set these prefs to false on the about:config page.

  • media.windows-media-foundation.enabled
  • media.directshow.enabled

You can try to switch to the Yahoo Flash player.

This extension allows to switch between the Flash player and the HTML5 media player on the YouTube website. YouTube Flash Video Player:

You can try to disable the HTML5 media player and set these prefs to false on the <b>about:config</b> page. *media.windows-media-foundation.enabled *media.directshow.enabled You can try to switch to the Yahoo Flash player. This extension allows to switch between the Flash player and the HTML5 media player on the YouTube website. YouTube Flash Video Player: *https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Question owner

cor-el said

You can try to disable the HTML5 media player and set these prefs to false on the about:config page.
  • media.windows-media-foundation.enabled
  • media.directshow.enabled
You can try to switch to the Yahoo Flash player. This extension allows to switch between the Flash player and the HTML5 media player on the YouTube website. YouTube Flash Video Player:

Just tried it and it's still hanging like before. This is all just so bizarre. I feel like all of these options should work but nothing is happening.

''cor-el [[#answer-782142|said]]'' <blockquote> You can try to disable the HTML5 media player and set these prefs to false on the <b>about:config</b> page. *media.windows-media-foundation.enabled *media.directshow.enabled You can try to switch to the Yahoo Flash player. This extension allows to switch between the Flash player and the HTML5 media player on the YouTube website. YouTube Flash Video Player: *https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ </blockquote> Just tried it and it's still hanging like before. This is all just so bizarre. I feel like all of these options should work but nothing is happening.

Modified by VictorMarrero