X
Tap here to go to the mobile version of the site.

Support Forum

Icons and images are distorted. Only happens in firefox. Resetting doesn't help.

Posted

Hey there,

So today when I opened Firefox, this is how it looked. Icons and images are distorted. Text is fine, scrolling is fine. And this only occurs in Firefox (i.e. every other program on my computer including other browsers are fine).

Any idea what this is and how to fix it?

Thanks.

Hey there, So today when I opened Firefox, this is how it looked. Icons and images are distorted. Text is fine, scrolling is fine. And this only occurs in Firefox (i.e. every other program on my computer including other browsers are fine). Any idea what this is and how to fix it? Thanks.

Chosen solution

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Read this answer in context 6

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

More Information

Wesley Branton
  • Top 25 Contributor
377 solutions 3618 answers

Chosen Solution

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Question owner

Woops, just added the screenshot.

Woops, just added the screenshot.

Question owner

Thank you, Wesley!!! What a simple fix!

Thank you, Wesley!!! What a simple fix!
Wesley Branton
  • Top 25 Contributor
377 solutions 3618 answers

Glad to hear that the issue is now solved. Thanks for contacting the Mozilla Support Team.

Glad to hear that the issue is now solved. Thanks for contacting the Mozilla Support Team.