X
Tap here to go to the mobile version of the site.

Support Forum

Can't browse pictures with arrow keys in Facebook

Posted

This problem started about a few days ago. I can't use my arrow keys to browse (navigate) pictures in Facebook. For example, if I press the right arrow key, Facebook will display the next picture. But for some reasons, I can't do it anymore. And also, if I try to press the arrow key, the comment section under the picture will disappear.

I've tried to start Firefox in Safe Mode, reset it to it's "virgin" state but the problem still remains.

Also, I've also tried to browse pictures on other browsers (IE, Chrome, Opera) but it just won't change to the next/previous picture.

Any ideas how to solve my petty problem? :v

And thanks in advance.

Also, sorry for my bad English.

This problem started about a few days ago. I can't use my arrow keys to browse (navigate) pictures in Facebook. For example, if I press the right arrow key, Facebook will display the next picture. But for some reasons, I can't do it anymore. And also, if I try to press the arrow key, the comment section under the picture will disappear. I've tried to start Firefox in Safe Mode, reset it to it's "virgin" state but the problem still remains. Also, I've also tried to browse pictures on other browsers (IE, Chrome, Opera) but it just won't change to the next/previous picture. Any ideas how to solve my petty problem? :v And thanks in advance. Also, sorry for my bad English.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 18.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

FredMcD
  • Top 10 Contributor
4305 solutions 60410 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

@FredMcD

I've already tried deleting cache, cookies and starting Firefox in Safe Mode.

Also, turning off Use Hardware Acceleration didn't help.

Bottom line is, problem is still there.

@FredMcD I've already tried deleting cache, cookies and starting Firefox in Safe Mode. Also, turning off '''Use Hardware Acceleration''' didn't help. Bottom line is, problem is still there.
FredMcD
  • Top 10 Contributor
4305 solutions 60410 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.


Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' ------------- '''[https://www.mozilla.org/en-US/plugincheck/ Use this link to check that your plugins are up-to-date.]''' If any are listed as unknown or research, do not worry about them.
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40417 answers

http://kb.mozillazine.org/Accessibility.browsewithcaret

(Tools) > Options --> Advanced > General Always use the cursor keys to navigate within pages

http://kb.mozillazine.org/Accessibility.browsewithcaret ''(Tools) >'' Options --> Advanced > General '''Always use the cursor keys to navigate within pages'''

Question owner

@FredMcD

There's nothing wrong with my addons. Everything is up to date.

@FredMcD There's nothing wrong with my addons. Everything is up to date.

Question owner

@the-edmeister

I've also tried using Browsing with Caret and """Always use cursor keys to navigate within pages""" but the problem still remains.

@the-edmeister I've also tried using Browsing with Caret and """Always use cursor keys to navigate within pages""" but the problem still remains.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

It is possible that Anti-Virus software is causing problems. Try to disable Anti-Virus software temporarily to see if that makes a difference.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

It is possible that Anti-Virus software is causing problems. Try to disable Anti-Virus software temporarily to see if that makes a difference. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Hi Ken, what kind of photo display are you having this problem on?

If I click a photo in my news feed, it launches a theater display (black background) with a large image on the left and comments on the right side. The arrow keys work for me there.

If I go to someone's timeline and click Photos, and click the first one, I get a similar display and arrow keys work for me there.

Do either of those work for you the way mine work?

Since you mentioned having this issue in multiple browsers, it does sound as though an external program might be blocking or modifying something as suggested in the previous post.

Hi Ken, what kind of photo display are you having this problem on? If I click a photo in my news feed, it launches a theater display (black background) with a large image on the left and comments on the right side. The arrow keys work for me there. If I go to someone's timeline and click Photos, and click the first one, I get a similar display and arrow keys work for me there. Do either of those work for you the way mine work? Since you mentioned having this issue in multiple browsers, it does sound as though an external program might be blocking or modifying something as suggested in the previous post.

Question owner

@cor-el

Just tried to disable my Anti-virus Program, it didn't work.

@cor-el Just tried to disable my Anti-virus Program, it didn't work.

Question owner

@jscher2000

I usually open the pictures in a new tab instead of clicking them to open up the theater mode, like you've just mentioned.

The arrow keys thing works with the theater mode. And thanks for tip. I didn't know about this one.

But the arrow keys thing doesn't work if I open the picture in a new tab. And when the problem occurred, I'm quite sure that I didn't install or uninstall any programs, toolbars or anything.

@jscher2000 I usually open the pictures in a new tab instead of clicking them to open up the theater mode, like you've just mentioned. The arrow keys thing works with the theater mode. And thanks for tip. I didn't know about this one. But the arrow keys thing doesn't work if I open the picture in a new tab. And when the problem occurred, I'm quite sure that I didn't install or uninstall any programs, toolbars or anything.
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40417 answers

Please provide an example page URL where you have that issue.

Please provide an example page URL where you have that issue.

Question owner

@the-edmeister Here's the link: https://www.facebook.com/Tomia.OfficialPage/photos/ms.c.eJw9zskRxEAIA8CMXAxCHPknZg8L~_2xUgDLTDlhRInrqyWvluYbGGGn0EFkzvxmcNi7~;ci~_bfZxoa67ZhoxN~_h82R7btn~_u9z1gz2uS67r1MH3v8~_p~;pY~_z~_wAv8ki2Z.bps.a.888412311233681.1073742085.137464896328430/888413597900219/?type=1
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40417 answers

The photo viewer on that page goes thru the images just fine for me when using a right to left arrow key.

The photo viewer on that page goes thru the images just fine for me when using a right to left arrow key.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Hi Ken, I tried that page (logged out) and the arrow keys don't do anything for me unless I click the "Open photo viewer" icon, which launches a theater display. Since you encounter this issue in all browsers, it could be a FB change, but I haven't digged into the page's scripts...

Correction: As you mentioned before, pressing either the left or right arrow key hides the comments. Something is broken.

Hi Ken, I tried that page (logged out) and the arrow keys don't do anything for me unless I click the "Open photo viewer" icon, which launches a theater display. Since you encounter this issue in all browsers, it could be a FB change, but I haven't digged into the page's scripts... '''Correction:''' As you mentioned before, pressing either the left or right arrow key hides the comments. Something is broken.

Modified by jscher2000

Question owner

@the-edmeister

But I can't use my arrow keys to goes through the images. The only thing that the arrow keys do is hide the comments section.

@the-edmeister But I can't use my arrow keys to goes through the images. The only thing that the arrow keys do is hide the comments section.

Question owner

@jscher2000

Thanks again.

@jscher2000 Thanks again.