Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't browse pictures with arrow keys in Facebook

  • 16 replies
  • 1 has this problem
  • 9 views
  • Last reply by KenKenta

more options

This problem started about a few days ago. I can't use my arrow keys to browse (navigate) pictures in Facebook. For example, if I press the right arrow key, Facebook will display the next picture. But for some reasons, I can't do it anymore. And also, if I try to press the arrow key, the comment section under the picture will disappear.

I've tried to start Firefox in Safe Mode, reset it to it's "virgin" state but the problem still remains.

Also, I've also tried to browse pictures on other browsers (IE, Chrome, Opera) but it just won't change to the next/previous picture.

Any ideas how to solve my petty problem? :v

And thanks in advance.

Also, sorry for my bad English.

All Replies (16)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

@FredMcD

I've already tried deleting cache, cookies and starting Firefox in Safe Mode.

Also, turning off Use Hardware Acceleration didn't help.

Bottom line is, problem is still there.

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.


Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.

more options

http://kb.mozillazine.org/Accessibility.browsewithcaret

(Tools) > Options --> Advanced > General Always use the cursor keys to navigate within pages

more options

@FredMcD

There's nothing wrong with my addons. Everything is up to date.

more options

@the-edmeister

I've also tried using Browsing with Caret and """Always use cursor keys to navigate within pages""" but the problem still remains.

more options

It is possible that Anti-Virus software is causing problems. Try to disable Anti-Virus software temporarily to see if that makes a difference.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

more options

Hi Ken, what kind of photo display are you having this problem on?

If I click a photo in my news feed, it launches a theater display (black background) with a large image on the left and comments on the right side. The arrow keys work for me there.

If I go to someone's timeline and click Photos, and click the first one, I get a similar display and arrow keys work for me there.

Do either of those work for you the way mine work?

Since you mentioned having this issue in multiple browsers, it does sound as though an external program might be blocking or modifying something as suggested in the previous post.

more options

@cor-el

Just tried to disable my Anti-virus Program, it didn't work.

more options

@jscher2000

I usually open the pictures in a new tab instead of clicking them to open up the theater mode, like you've just mentioned.

The arrow keys thing works with the theater mode. And thanks for tip. I didn't know about this one.

But the arrow keys thing doesn't work if I open the picture in a new tab. And when the problem occurred, I'm quite sure that I didn't install or uninstall any programs, toolbars or anything.

more options

Please provide an example page URL where you have that issue.

more options
more options

The photo viewer on that page goes thru the images just fine for me when using a right to left arrow key.

more options

Hi Ken, I tried that page (logged out) and the arrow keys don't do anything for me unless I click the "Open photo viewer" icon, which launches a theater display. Since you encounter this issue in all browsers, it could be a FB change, but I haven't digged into the page's scripts...

Correction: As you mentioned before, pressing either the left or right arrow key hides the comments. Something is broken.

Modified by jscher2000

more options

@the-edmeister

But I can't use my arrow keys to goes through the images. The only thing that the arrow keys do is hide the comments section.

more options

@jscher2000

Thanks again.