Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default Language changed by website - Difficult to Navigate menus in what appears to be Talagog.

  • 11 replies
  • 2 have this problem
  • 35 views
  • Last reply by cor-el

more options

Some website from a news channel changed my default language settings and removing Firefox library file did not solve. Please advise.

All Replies (11)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu, choose History, and then "Clear Recent History...".
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Yes - I'm familiar with this. However, I can not read any of the menus...

more options

Try to download and (re)install the en-US Firefox version.

You can find the full version of the current Firefox release (40.0.3) in all languages and all operating systems here:

more options

Yes - had done that and the corruption remained. I eventually had to root out the library folders and delete them. what a nasty trick... Very surprised that firefox does not provide greater warning before sites change the default application language.

more options

To the best of my knowledge, no websites are able to change the language of your Firefox browser because that would involve downloading an entirely new version in a different language from the Mozilla website.

more options

I'm certain that I did not download a non english version TWICE... Not even sure how I would find a malay or filipino language version...

more options

That is very strange then. I would suggest that it is malware, but since you are on a Mac, that is most likely not the issue.

Click here to download Firefox again

Then can you post a screenshot of the issue please? If you need help to create a screenshot, please see How do I create a screenshot of my problem?

more options

yes - i already solved my problem as noted before... the problem is that firefox can be hijacked in this way - most likely by malicious javascript files.

and macs are not that hard to infect unfortunately ...

anyway - unless a Firefox staff member with knowledge of their product and attack vectors can respond, let's not continue this thread.

more options

You might have had some specific pref settings that were stored in the prefs.js file. If you still have files in the trash then you can check out the prefs.js file.

more options

Yes - that is unfortunately likely. My point @MOZILLA is that Firefox should not be able to be hijacked in this manner.

more options

We have seen cases reported where the language after an update got changed for unknown reasons. Installing a full locale version of the correct language would fix this for the user interface (general.useragent.locale), but the installed languages (intl.accept_languages) could still have the wrong setting.