Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Saving Username AND password for facebook isn't working (autocomplete problem)

  • 3 replies
  • 1 has this problem
  • 15 views
  • Last reply by cor-el

more options

I am using in firefox a master password, and saving all the usernames and passwords for various logins to sites.

when logging in to facebook, firefox never auto-completes the username, it just autocompletes the password. I have to type the email-address every time I log in to FB, and this is annoying. Until now, I could not find any solution, even after searching extensively the web and the mozilla support. Even the "remember autocomplete widget (bookmarklet)" (https://www.squarefree.com/bookmarklets/forms.html#remember_password) did not help me in the case of facebook (but helped in the case of other sites). It seems that facebook has special settings that override whatever I set up in firefox.

is there any hack or solution for this?

thanks in advance!

All Replies (3)

more options

It shouldn't be necessary to use a bookmarklet to disable autocomplete=off.

  • Bug 956906 - ignore autocomplete="off" when offering to save passwords via the password manager

This is controlled via the signon.storeWhenAutocompleteOff pref.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


Did you check the exceptions?

  • Tools > Options > Security: Passwords: Exceptions

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

thank you, cor-el, for your recommendations. Unfortunately, they do not help. In fact, I adopted the solution with the mentioned bookmarklet long ago, after I discovered that the settings in the about;config do not help for certain autocomplete cases. It was the case of some banking accounts, for example. It seems that some websites have implemented high security measures, that override any settings in autocomplete from firefox, and still force you to type in the password and/or username.

I was able to override this with the bookmarklet, but there is just one exception: Facebook.

So, my question is still awaiting answers: who is experiencing similar problems? did you solve them? how?

more options

Do you mean storing names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox?

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

You can remove the cookies from a website to make the website forget about you.