X
Tap here to go to the mobile version of the site.

Support Forum

What can I do to stop Firefox from reordering the browser tabs on the Windows toolbar?

Posted

Firefox, at random, reorders my Firefox tabs on the Windows toolbar. I rely on Firefox and always have several tabs (sessions?) on the Windows toolbar. I prefer to have my email in the first tab, but at times, it will shift the order. This problem comes and goes with different updates to Firefox.

I can work-around this by having the email tab open, terminating Firefox in Task Manager, and restarting Firefox. Doing this will make the email tab the first in the list/first to recover. I would prefer knowing how to move the tab back to its original location without this work-around.

Apologies if I'm getting the terms wrong, but I do not mean the individual website tabs within Firefox, but the Firefox session tabs on the Windows toolbar.

Thanks!

Firefox, at random, reorders my Firefox tabs on the Windows toolbar. I rely on Firefox and always have several tabs (sessions?) on the Windows toolbar. I prefer to have my email in the first tab, but at times, it will shift the order. This problem comes and goes with different updates to Firefox. I can work-around this by having the email tab open, terminating Firefox in Task Manager, and restarting Firefox. Doing this will make the email tab the first in the list/first to recover. I would prefer knowing how to move the tab back to its original location without this work-around. Apologies if I'm getting the terms wrong, but I do not mean the individual website tabs within Firefox, but the Firefox session tabs on the Windows toolbar. Thanks!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • PDF Architect 3
  • Shockwave Flash 18.0 r0
  • VLC media player Web Plugin
  • WildTangent Games App V2 Presence Detector

Application

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Avast Online Security 10.2.0.187 (wrc@avast.com)
  • Kaspersky Protection 4.6.0.375 (light_plugin_D772DC8D6FAF43A29B25C4EBAA5AD1DE@kaspersky.com)
  • Video Downloader professional 1.97.37.1-signed (ffext_basicvideoext@startpage24)
  • Lightbeam 1.2.1.1-signed (jid1-F9UJ2thwoAm5gQ@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17999
  • driverDate: 10-28-2013
  • driverDate2:
  • driverVersion: 10.18.10.3345
  • driverVersion2:
  • failures: [u'[GFX1]: Failed to create software bitmap: Size(72,72) Code: 0x8899000c', u'[GFX1]: Failed to create software bitmap: Size(16,16) Code: 0x8899000c', u'[GFX1-]: Failed to allocate a surface due to invalid size Size(0,1)', u'[GFX1-]: Failed to allocate a surface due to invalid size Size(0,1)', u'[GFX1-]: Failed to allocate a surface due to invalid size Size(0,1)', u'[GFX1-]: Failed to allocate a surface due to invalid size Size(0,1)']
  • indices: [0, 31, 27, 28, 29, 30]
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 4
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4307 solutions 60475 answers

I've called the big guys to help you. Good luck.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

I've called the big guys to help you. Good luck. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?

Question owner

Fred,

Thanks, but I'm pretty sure that this would have the same effect as what I do when I terminate and then restart Firefox. In that case, I make sure that my only open Firefox tab is the one with email so it will be the first tab when I again start Firefox. Note that I cannot force this issue. It happens at random.

I was hoping that there would be a way to reorder the tabs. This minor issue is not something I can replicate at will, but sometimes it seems that if I spend a lot of time in one of the other tabs, that tab becomes the first one in order.

This happens with random Firefox updates. Admittedly, this seemed to go away for a long time(during the past several updates), but is now happening again with my latest version: 40.0.3.

For anyone reading this, I want to be clear that although this is annoying to me, in the overall scheme of things, it's really minor. You won't see crash reports from me because A) Firefox is so reliable, it's extremely rare that I really have an issue, and B) Almost always, I'm terminating it with the task manager so I can get back all my tabs when I restart it. At that point, Firefox is prompting me to submit the data, but I won't because it wasn't a problem to be resolved.

Also, I want to thank the Firefox team for an awesome product!

Fred, Thanks, but I'm pretty sure that this would have the same effect as what I do when I terminate and then restart Firefox. In that case, I make sure that my only open Firefox tab is the one with email so it will be the first tab when I again start Firefox. Note that I cannot force this issue. It happens at random. I was hoping that there would be a way to reorder the tabs. This minor issue is not something I can replicate at will, but sometimes it seems that if I spend a lot of time in one of the other tabs, that tab becomes the first one in order. This happens with random Firefox updates. Admittedly, this seemed to go away for a long time(during the past several updates), but is now happening again with my latest version: 40.0.3. For anyone reading this, I want to be clear that although this is annoying to me, in the overall scheme of things, it's really minor. You won't see crash reports from me because A) Firefox is so reliable, it's extremely rare that I really have an issue, and B) Almost always, I'm terminating it with the task manager so I can get back all my tabs when I restart it. At that point, Firefox is prompting me to submit the data, but I won't because it wasn't a problem to be resolved. Also, I want to thank the Firefox team for an awesome product!

Modified by Boaterdude

guigs 1072 solutions 11697 answers

There is a tweak to reorder them mentioned here: http://superuser.com/questions/680406/how-to-order-windows-of-the-same-pro... however that doe not fix the issue. It might be useful for the times that it does happen however.

There is a tweak to reorder them mentioned here: [http://superuser.com/questions/680406/how-to-order-windows-of-the-same-program-on-taskbar] however that doe not fix the issue. It might be useful for the times that it does happen however.

Question owner

guigs,

Thank you. Although it appears that there is software to correct for this, I prefer not to install additional software for a resolution. I will hope that the next Firefox update resolves it, like it has done in the past. In the meantime, I'll just terminate and restart Firefox as I have been doing.

-Jim

guigs, Thank you. Although it appears that there is software to correct for this, I prefer not to install additional software for a resolution. I will hope that the next Firefox update resolves it, like it has done in the past. In the meantime, I'll just terminate and restart Firefox as I have been doing. -Jim