X
Tap here to go to the mobile version of the site.

Support Forum

Spellcheck garbling words

Posted

For some reason, when I attempt to correct misspelled words in Mozilla Firefox (even after a install and excluding installing addons) the corrected words become fused with other words near it, creating garbled text as shown in the screenshots below of a fix before and after

Before: http://i.imgur.com/6mMmhTe.png After: http://i.imgur.com/OmihtqV.png

For some reason, when I attempt to correct misspelled words in Mozilla Firefox (even after a install and excluding installing addons) the corrected words become fused with other words near it, creating garbled text as shown in the screenshots below of a fix before and after Before: http://i.imgur.com/6mMmhTe.png After: http://i.imgur.com/OmihtqV.png

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Battlelog Game Launcher (2.7.1)
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

Question owner

In case the images go down in the future here is uploaded copies.

In case the images go down in the future here is uploaded copies.
FredMcD
  • Top 10 Contributor
4308 solutions 60504 answers

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district is selected.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


I've called the big guys to help you. Good luck.

Type '''about:preferences#content'''<enter> in the address bar. On the bottom of the page, find '''Languages.''' To its right, press the '''Choose''' button. Make sure the correct language and district is selected. -------------------- Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? I've called the big guys to help you. Good luck.
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

So

all garbld

became

agarbledll

That's really dysfunctional.

Does the problem happen even with the very unfancy editing controls on this site, or is it specific to the forms on some site(s)?

So all garbld became a'''garbled'''ll That's really dysfunctional. Does the problem happen even with the very unfancy editing controls on this site, or is it specific to the forms on some site(s)?
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

Is this on Facebook? We have a similar thread: Spellcheck moves the word when you try to allow it to correct spelling errors in Facebook.

In my test, I do see this problem in the comment box for items in my news feed. I can't figure out the pattern of how far left the correction is inserted. It seems kind of random.

As a workaround, select the word you plan to replace before right-clicking it. That seems to prevent Facebook from inserting the replacement in a random location left of what you intended.

Hopefully they will fix this!!

Is this on Facebook? We have a similar thread: [https://support.mozilla.org/questions/1080254 Spellcheck moves the word when you try to allow it to correct spelling errors in Facebook.] In my test, I do see this problem in the comment box for items in my news feed. I can't figure out the pattern of how far left the correction is inserted. It seems kind of random. As a workaround, select the word you plan to replace before right-clicking it. That seems to prevent Facebook from inserting the replacement in a random location left of what you intended. Hopefully they will fix this!!