X
Tap here to go to the mobile version of the site.

Support Forum

Why does Firefox 40 fail to connect after a session offline?

Posted

I often spend a long time offline, updating website pages locally. When I then try to go online, Firefox just says "Done" but fails to connect to anywhere. This isn't after clicking "work offline" - should I?

I often spend a long time offline, updating website pages locally. When I then try to go online, Firefox just says "Done" but fails to connect to anywhere. This isn't after clicking "work offline" - should I?

Additional System Details

Installed Plug-ins

  • Amazon MP3 Downloader Plugin 1.0.18
  • Content Blocker Extension
  • Foxit Reader Plug-In For Firefox and Netscape
  • Garmin Communicator Plug-In 4.2.0.0 BETA
  • GEPlugin
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Nokia Suite Enabler Plugin
  • Online Banking Extension
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • Virtual Keyboard
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Helpful Reply

If you are still "off line," that means no internet access.

About this "Done" business,

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

If you are still "off line," that means no internet access. About this "Done" business, Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!

Question owner

Thanks, but to clarify: I'm not setting Firefox to "offline". I just open a local file (one of the pages of the website prior to uploading it to a server), and then keep hitting Reload as I make adjustments in an html editor, to check that it is coming out right. So far so good. However, if I then ask Firefox for a New Tab and try using that to go online to find something (eg correct ASCII code or CSS construction), the status bar will say "Done" as normal, but nothing actually happens. This did not happen prior to v40 (I'm on 40.0.02). It seems as if Firefox is now switching itself to offline mode (ie "don't connect to the internet") after x minutes of working locally, as it needs to be restarted to "kick" it to connect. Cheers - Bob Downing

Thanks, but to clarify: I'm not setting Firefox to "offline". I just open a ''local'' file (one of the pages of the website prior to uploading it to a server), and then keep hitting Reload as I make adjustments in an html editor, to check that it is coming out right. So far so good. However, if I then ask Firefox for a New Tab and try using that to go online to find something (eg correct ASCII code or CSS construction), the status bar will say "Done" as normal, but nothing actually happens. This did not happen prior to v40 (I'm on 40.0.02). It seems as if Firefox is now switching itself to offline mode (ie "don't connect to the internet") after x minutes of working locally, as it needs to be restarted to "kick" it to connect. Cheers - Bob Downing
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Instead of just opening a new tab, try a bookmark (open new tab/window).

I've called the big guys to help you. Good luck.

Instead of just opening a new tab, try a bookmark (open new tab/window). I've called the big guys to help you. Good luck.

Question owner

Thanks, Fred. That's one workaround, but I was hoping for a solution!

Thanks, Fred. That's one workaround, but I was hoping for a solution!
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Did using a bookmark work?

Check your current "Net Tab" setting;

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.newtab.url This tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

Did using a bookmark work? Check your current "Net Tab" setting; Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. Type '''browser.newtab.url''' This tells Firefox what to show when a new tab is opened. If you want, right click and select '''Modify'''. You can change the setting to; '''about:home''' (Firefox default home page), '''about:newtab''' (shows the sites most visited), '''about:blank''' (a blank page), or you can enter any '''web page''' or '''about: page''' you want. The same instructions are used for the new window setting, listed as '''browser.startup.homepage'''.
guigs 1072 solutions 11697 answers

So when you open a local html file it loads, but if you open a new tab there is no webpage displayed. Is it successfully sending the page request?

You can check in the Web Console from Tools > Web Developer > Web Console

So when you open a local html file it loads, but if you open a new tab there is no webpage displayed. Is it successfully sending the page request? You can check in the Web Console from Tools > Web Developer > Web Console

Question owner

Thanks Fred and guigs. Using bookmarks wasn't helping. My New Tab 'home' page is in fact my standard Firefox startup 'home' page, a plain html page with a number of regularly used addresses (eg Google, bank) so I can start off in the direction I want. So I'd have the first tab open showing a page from the offline local site I'm working on, and the second tab with this 'home' page. Clicking on a link to Google or the W3 CSS help produced nothing - just a 'Done' in the Firefox status bar (which I've kept using the Status-4-evar addon).

I've tried using the Web Console, but don't understand it; plus, it shows nothing anyway. (It did tell me something was deprecated when I just opened it, but not where Firefox thought it was going or anything remotely like a ping or ftp display).

Thanks Fred and guigs. Using bookmarks wasn't helping. My New Tab 'home' page is in fact my standard Firefox startup 'home' page, a plain html page with a number of regularly used addresses (eg Google, bank) so I can start off in the direction I want. So I'd have the first tab open showing a page from the offline local site I'm working on, and the second tab with this 'home' page. Clicking on a link to Google or the W3 CSS help produced nothing - just a 'Done' in the Firefox status bar (which I've kept using the Status-4-evar addon). I've tried using the Web Console, but don't understand it; plus, it shows nothing anyway. (It did tell me something was deprecated when I just opened it, but not where Firefox thought it was going or anything remotely like a ping or ftp display).