Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox is soooooooooooooo slow displaying pages on any and all websites

  • 4 replies
  • 2 have this problem
  • 21 views
  • Last reply by mark7773

more options

Basically it takes minutes to display a single page on any and all websites . Even Google Most of the time even after minutes of waiting , the page will display without images. I have to close and reopen FF to view that page and even that doesn't resolve the issue

All Replies (4)

more options

Have your ISP check your service.


Unplug your modem power for a 10 count to re-boot it.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

It is possible that your firewall or other security software blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process.

See:


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

FredMcD said

Have your ISP check your service.

Unplug your modem power for a 10 count to re-boot it.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Done that several times Issue is with FF only. I have Opera , IE and Safari installed and none of them has that issue

more options

cor-el said

It is possible that your firewall or other security software blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process. See:

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

will try that ... thx