Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Netflix won't play even with Silverlight installed

  • 2 replies
  • 3 have this problem
  • 51 views
  • Last reply by jbrts

more options

Hello. Using Firefox 40.0.2. Tried to watch Netflix, but I'm only getting a prompt to install Silverlight, which I've done (uninstall/reinstall) 3 times. It won't show up as a plug-in. Netflix plays fine on Chrome. Would much rather use FF. How can I fix this? Thanks.

All Replies (2)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

Sorry, this didn't do it. Thanks for the advice.

I am running El Capitan, if that changes anything. Turned off Hardware Acceleration, uninstalled and reinstalled Silverlight. Still getting prompted to install. Still using Chrome until then.