Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 5 replies
  • 1 has this problem
  • Last reply by jscher2000

more options

I'm getting a series of crashes of Firefox (I have the latest version) ever since I mistakenly "upgraded" to Windows 10. Windows 8.1 was working absolutely fine, what was I thinking??? Anyway, I'm getting crashes and then Firefox offers to restore where I was but then cannot do so. I followed the instructions on getting the Report ID


Modified by cor-el

All Replies (5)

more options 40

The crash report flagged these programs;

Appleffdav.dll = iCloud Control Panel = Apple Computer for the Windows

atidxx32.dll = Advanced Micro Devices = Radeon DirectX

icudt52.dll = International Components for Unicode ++++++++++++++++++++++++++++++++ Total Virtual Memory 4294836224

Available Virtual Memory 2828656640

System Memory Use Percentage 58

Available Page File 3347001344

Available Physical Memory 3179913216

This is for Sumo's

Related Bugs

1145143 REOPENED --- Firefox 38a2 reliably crashes itself and the NVIDIA driver on my laptop 1116812 RESOLVED FIXED CompositorD3D11::HandleError coming from mozilla::layers::CompositorD3D11::UpdateRenderTarget() probably from TDRs 1104008 RESOLVED FIXED crash in CompositorD3D11::UpdateRenderTarget

Get the current full installers for the above.

Firefox uses too much memory (RAM) - How to fix This article describes how to make Firefox use less memory to make it run faster and prevent crashes.

more options

If you have an iCloud add-on, definitely try disabling that or removing it on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right, if in doubt, disable (or remove).

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Note: If Firefox does not stay up long enough to work with the Add-ons page in normal mode, you can start Firefox in its Safe Mode. Here's how:

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Did not have an iCloud add-on. Sorry.

more options

The first reply I rec'd was incomprehensible to me. What was I supposed to do?

I don't know where the iCloud control panel is or what I should do about it. And: I don't know what to do with or about these: atidxx32.dll = Advanced Micro Devices = Radeon DirectX

icudt52.dll = International Components for Unicode

more options

The crashes are related to DirectX, a Windows graphics technology, which can indicate an incompatibility between Firefox and your graphics card/chipset drivers. Because Windows 10 is so new, there have been problems where Firefox was not tested with the latest drivers that shipped with the final version of the OS.

Could you try disabling Firefox from using hardware acceleration:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check your computer manufacturer's website to see whether any graphics card/chipset driver updates are available for your system. See: Upgrade your graphics drivers to use hardware acceleration and WebGL. Since yours showed a July release date in the other thread, those may well be the latest.