X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Can't log on to website after refresh, and reinstall

Posted

Hello, i recently refreshed as well reinstalled my firefox and chrome browsers, since there was a redirection virus which leading to Yahoo.com repeatedly on certain websites. Now i can't log on to my university's website as it says it has Error code: sec_error_bad_signature, even though previously i could log on before i caught this virus and fixed it?? can you please help me solve this problem?

Hello, i recently refreshed as well reinstalled my firefox and chrome browsers, since there was a redirection virus which leading to Yahoo.com repeatedly on certain websites. Now i can't log on to my university's website as it says it has Error code: sec_error_bad_signature, even though previously i could log on before i caught this virus and fixed it?? can you please help me solve this problem?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Garena Talk Plugin
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • My.com Games Detector Plug-in
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

jscher2000
  • Top 10 Contributor
8953 solutions 73374 answers

Is it just on one site or do you get that error on many sites?

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis.

To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

Is it just on one site or do you get that error on many sites? The most common reason for getting "sec_error_bad_signature" ''on numerous sites'' seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis. To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.