Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search error

  • 9 replies
  • 27 have this problem
  • 598 views
  • Last reply by Ladihawk

more options

The past several days anytime i try to use either yahoo or google search engine i keep getting a message "This Connection is Untrusted". I have tried refreshing firefox and it does not matter it still does the same thing. I have enclosed a screenshot showing this. I have Firefox 39.0.3. Can someone please help me? I am not to computer savy so please try to make it simple.

Thanks.

Chosen solution

I did not have to go through all those steps listed in that article but the certificate was saved and i then went to FF options and made google the search engine and all is working. Thanks a bunch for the help and i will bookmark this in case it happens again.

Read this answer in context 👍 2

All Replies (9)

more options

For some reason the screenshot did not load so here it is.

more options

Since you use Kaspersky, a possible reason for this is Firefox not being set up to work with its feature to scan your internet traffic. For secure connections, Kaspersky has to present "fake" certificates to Firefox.

Kaspersky usually injects its signing certificate into Firefox's certificate file (cert8.db) automatically, but a Refresh removes that file. I don't know whether you can coax Kaspersky to do that again, or whether you will need to fix it manually.

I found these steps in a post on the Kaspersky forums. The actual path on disk may vary depending on your product:


Open Firefox's Certificate Manager:

"3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > View Certificates button

In the Certificate Manager dialog, click the "Authorities" mini-tab

If you see an existing "Kaspersky Anti-Virus Personal Root Certificate"

Select it and Click "Delete or Distrust"

Now click "Import..."

Proceed to "C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\"

Select "(fake)Kaspersky Anti-Virus Personal Root Certificate.cer" and Open!


Does that work on your Firefox?

more options

I should have mentioned that there are several other possible reasons for problems with secure sites. If the above does not help, please expand the Technical Details section of the error page and look for an error code in parentheses (separated_with_underscore_characters) and paste that into a reply, since it may help identify the problem.

more options

OK i tried to follow the above path but there is no data. I then tried going to program files and then to Kaspersky but again no data in there either nor any part of the above path could be found. I have enclosed another screenshot showing the details under technical details.

more options

Okay, did you have to create an exception to use this site in Firefox or is the secure certificate problem limited to only Google and Yahoo?

If you created an exception for this site, please compare the certificate with the attached screen shot. You can do that by clicking the padlock (or warning triangle) in the address bar, then More Information, then View Certificate. In particular, what do you see under "Issued by" and in the Certificate Hierarchy?

more options

Strange i replied to this but i do not see it. I tried to do a certificate under servers and i see it listed there but it still does not allow me to use google search nor is there a way to click on I understand the risks like i did with yahoo which now works fine. Here is a screenshot showing what i have done.

more options

Reply deleted.

Modified by Ladihawk

more options

Are those "Kaspersky Lab ZAO" entries the ones you just created, or were those there before?

I think you would have better luck with the import strategy. If the certificate can't be found in the usual location, you could try exporting it from the Kaspersky setting or from Internet Explorer.

Maybe this old support article? http://support.kaspersky.com/us/9093#block1

more options

Chosen Solution

I did not have to go through all those steps listed in that article but the certificate was saved and i then went to FF options and made google the search engine and all is working. Thanks a bunch for the help and i will bookmark this in case it happens again.