Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When i just open the browser , why every time the site (Bing/yahoo/...) will auto starting ? how can i stop this & also free from extra tab without any site?

  • 1 reply
  • 1 has this problem
  • 6 views
  • Last reply by jscher2000

more options

TWO TYPES PROBLEM....

1.WHEN I JUST OPENED THE BROWSER , THEN SOMETIMES IT SHOW BING/YAHOO/OTHERS.....

2.WHEN I OPENING NEW TAB , THEN ALSO OPEN THE SAME THINGS.....

AS MY INTERNET DATA WAS LIMITED & COST , SO IT WAS BIG PROBLEM...

All Replies (1)

more options

When you start Firefox, or launch any new window, Firefox normally will load your home page(s). You can have more than one, and if you set more than one, each will have a separate tab. You can make sure you only have one by checking the Options page. See:

You can set it to just a blank page to save on data use.


Now, a new tab (Ctrl+t or the "+" button) is different, and it's a different setting. Normally, opening a new tab only opens a single page, and I'll list the steps for checking that a little later in this reply. IF MULTIPLE PAGES OPEN, it probably indicates a bad add-on. Have either of your extensions installed or updated recently?

To test with extensions disabled, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?


Here's how you can change your new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel. If the status says "locked" we will need to help you investigate an "autoconfig" file.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?