X
Tap here to go to the mobile version of the site.

Support Forum

Firefox prevents Windows from Shutting Down, left in a bad state

Posted

If I have any Firefox tabs open when I try to restart Windows, I get the "The following programs are preventing Windows from shutting down" error, with each of the FF tabs listed.

If I click Cancel and return to the desktop, Firefox is now in a bad state. It has minimized and cannot be restored; the tabs/window cannot be closed from the taskbar, etc. Usually I have to kill the FF process in the taskbar now.

This has happened for the past two years. Today I installed Win 10 Pro and it's still happening. Make this go away!

(Windows, always running the latest stable version of FF)

If I have any Firefox tabs open when I try to restart Windows, I get the "The following programs are preventing Windows from shutting down" error, with each of the FF tabs listed. If I click Cancel and return to the desktop, Firefox is now in a bad state. It has minimized and cannot be restored; the tabs/window cannot be closed from the taskbar, etc. Usually I have to kill the FF process in the taskbar now. This has happened for the past two years. Today I installed Win 10 Pro and it's still happening. Make this go away! (Windows, always running the latest stable version of FF)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 18.0 r0

Application

  • Firefox 39.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
  • Support URL: https://support.mozilla.org/1/firefox/39.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Disconnect 3.15.3.1-signed (2.0@disconnect.me)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 480
  • adapterDescription2:
  • adapterDeviceID: 0x06c0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1536
  • adapterRAM2:
  • adapterSubsysID: 14803842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16390
  • driverDate: 7-22-2015
  • driverDate2:
  • driverVersion: 10.18.13.5362
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 480 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Jhp512 5 solutions 28 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash. #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste those IDs into the "Post a Reply" box. ''' Note:''' If a recent Report ID does not start with '''bp-''' click on it to submit the report. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx29|width=500]] Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article.

Question owner

1. not crashing, just doing what I said above 2. no crash reports in the list 3. anything else I can provide you?

1. not crashing, just doing what I said above 2. no crash reports in the list 3. anything else I can provide you?
Jhp512 5 solutions 28 answers

I would recommend contacting Microsoft support at this point. I have went through all of my resources so far and am not finding anything.

Thank you

I would recommend contacting Microsoft support at this point. I have went through all of my resources so far and am not finding anything. Thank you

Helpful Reply

Heh. This is clearly not a Microsoft issue.

Any chance anybody else will be looking at this issue?

This was reported as a bug some years ago (I found it in the list), but listed as fixed.

Heh. This is clearly not a Microsoft issue. Any chance anybody else will be looking at this issue? This was reported as a bug some years ago (I found it in the list), but listed as fixed.
Jhp512 5 solutions 28 answers

Hopefully someone else will see this post who has a little bit more experience then I do with this! I am kind of new to this I am sorry that I was not more of assistance to you!

Hopefully someone else will see this post who has a little bit more experience then I do with this! I am kind of new to this I am sorry that I was not more of assistance to you!
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Helpful Reply

If you use "Clear history when Firefox closes" to clear Cookies then exclude the cookies and instead let the cookies expire when Firefox is closed to make them session cookies.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"

Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

If you use "Clear history when Firefox closes" to clear Cookies then exclude the cookies and instead let the cookies expire when Firefox is closed to make them session cookies. *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox" Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. *"Hang at exit": http://kb.mozillazine.org/Firefox_hangs *"Firefox hangs when you quit it": https://support.mozilla.org/kb/Firefox+hangs
Jhp512 5 solutions 28 answers

Thank you for assisting on this one cor-el! It is much appreciated!! :)

Thank you for assisting on this one cor-el! It is much appreciated!! :)

Question owner

I'm not sure I understand your answer. Are you suggesting that I do something? Can you clarify what that is?

I do have the "Until I close Firefox" option selected. Are you saying that this is the problem?

And as I state in my post, I'm not closing Firefox at all. I'm quitting Windows while FF is still running. Windows is sending FF the "Shutdown" message, and FF is either (a) saying "No" or (b) ignoring the command, and just sitting there.

The real problem, of course, is that when I come back to the desktop, FF is in a bad state which is equivalent to a Hang.

BTW, a quick Google shows this problem reported many many times. Nobody seems to have an answer, though...

I'm not sure I understand your answer. Are you suggesting that I do something? Can you clarify what that is? I do have the "Until I close Firefox" option selected. Are you saying that this is the problem? And as I state in my post, I'm not closing Firefox at all. I'm quitting Windows while FF is still running. Windows is sending FF the "Shutdown" message, and FF is either (a) saying "No" or (b) ignoring the command, and just sitting there. The real problem, of course, is that when I come back to the desktop, FF is in a bad state which is equivalent to a Hang. BTW, a quick Google shows this problem reported many many times. Nobody seems to have an answer, though...
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

It is not a good idea to let Windows close Firefox as it can take more time for Firefox to close completely. You should always close Firefox yourself to make sure that Firefox closes properly. You can check the Processes tab in the Windows Task Manager to check how long it takes for Firefox to close.

Are you using "Clear history when Firefox closes" to clear any data?

It is not a good idea to let Windows close Firefox as it can take more time for Firefox to close completely. You should always close Firefox yourself to make sure that Firefox closes properly. You can check the Processes tab in the Windows Task Manager to check how long it takes for Firefox to close. Are you using "Clear history when Firefox closes" to clear any data?