Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't allow me to access Google sites.

  • 5 replies
  • 11 have this problem
  • Last reply by philipp

more options

This has been happening for about three months. Originally refreshing the page a couple of times would let me through after displaying the standard 'connection to this site is untrusted' window. I have added all sites to the 'allow' page numerous times, both manually and by pressing the shortcut button that appears under the 'I understand the risks' tab. It never solved the problem. I even went as far as to remove and re-add the web sites back onto the allowed access list. I've checked windows defender. All web security was turned off. Nothing is working and this bug looks fatal.

As of about a month and a half ago, the 'I understand the risks' tab disappeared and was replaced with a 'Technical Details' tab. I will post the exact text below:

Technical Details uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported.

(Error code: sec_error_unknown_issuer)

This error happens repeatedly and is, as far as I can tell, unsolvable. I've refreshed Firefox, thinking it was a stereotypical error with the newest update, but nothing has changed. Please help! I need to access all my important documents and files from Google Drive! I've tried everything in my power is solve this myself, but nothing will work.

All Replies (5)

more options

hi matt, in order to know what's going on we probably need more information about the issuer of the failing certificate. please proceed like this: enter chrome://pippki/content/exceptionDialog.xul into the location bar, and in the page that opens, set the server location to "" in order to retrieve and view the certificate. then please report back with the data of the issued by section of the certificate viewer. thank you!

more options

Done. This is the exact window that came up. I tested it multiple times, with the same result...

Image isn't working, going to copy it line by line.

Exact 'Certificate Viewer' Window as follows:

Could not verify this certificate because the issuer is unknown.

Issued To Common Name (CN) Organization (O) Google Inc Organizational Unit (OU) <Not Part Of Certificate> Serial Number 51:BC:79:67:0D:3E:60:2C

Issued By Common Name (CN) Microsoft Family Safety Organization (O) Microsoft Family Safety Organizational Unit (OU) <Not Part Of Certificate>

Period of Validity Begins On 7/23/15 Expires On 10/20/15

Fingerprints SHA-256 Fingerprint 54:D2:0C:50:BC:C5:8B:76:96:09:1E:2F:6F:30:CB:E2:5B:8B:0C:C7:08:E7:1C:EF:FC:62:30:3D:0A:41:43:7A SHA1 Fingerprint 49:A8:9C:9C:54:CF:8E:80:4E:54:C1:4D:D5:8E:F7:5E:C4:58:4A:54

Modified by matt256

more options

great, thank you. this is caused by the microsoft family saftey setup switched on for that account - microsoft wants to intercept secure connections to some common sites like google, facebook, youtube and others for that. to get this to work in firefox, you'd first have to install the certificate of ms family safety into the browser's trust store. click on this link, check the box to Trust this CA to identify web sites & confirm the change.

alternatively you can try the manual procedure described at

Modified by philipp

more options

After following all steps from Microsoft, the result is a popup box telling me that I cannot access the certificate because I do not own the private key, despite the tutorial telling me that there was no private key required.

more options

when you click on - does the "Downloading Certificate" dialog box show up? if so, check the box to Trust this CA to identify web sites & confirm the change.

Modified by philipp