X
Tap here to go to the mobile version of the site.

Support Forum

Secure Connection Failed, Error code: sec_error_bad_signature

Posted

I installed windows 10 today. No when I go to websites such as amazon on google I get an error.

'An error occurred during a connection to www.google.co.uk. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature). The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the web site owners to inform them of this problem.'  

So annoying, all was ok until today. Bloody Microsoft! I have re-installed Firefox but that does not cure the problem. Am temporarily using Chrome which does not have the bug, I can buy things from amazon and search in google and use my gmail and youtube accounts. Can anyone help me please? Many thanks.

I installed windows 10 today. No when I go to websites such as amazon on google I get an error. 'An error occurred during a connection to www.google.co.uk. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature). The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the web site owners to inform them of this problem.' So annoying, all was ok until today. Bloody Microsoft! I have re-installed Firefox but that does not cure the problem. Am temporarily using Chrome which does not have the bug, I can buy things from amazon and search in google and use my gmail and youtube accounts. Can anyone help me please? Many thanks.

Chosen solution

hey, please disable https scaning within avast:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

Read this answer in context 108

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • WildTangent Games App V2 Presence Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5346 solutions 23603 answers

hi lincoln111, unfortunately this can currently happen on windows accounts that are restricted by the Microsoft Family safety settings - in order to disable those, please refer to http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

hi lincoln111, unfortunately this can currently happen on windows accounts that are restricted by the Microsoft Family safety settings - in order to disable those, please refer to http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

Question owner

Thank you phillipp. I have done as you advised, also using the information at http://windows.microsoft.com/en-GB/windows-live/family-safety-remove-uninstall-faq, I have removed my self from family safety. I am the only user of the pc. Then I restarted. Annoyingly I still have the same problem, Error code: sec_error_bad_signature, when I tried www.google.co.uk for example. Interestingly, I get the amazon home page coming up at www.amazon.co.uk, but when I try to sign in I get the error message. Also the www.bbc.co.uk website is fine. Could it be something to do with https ? Many thanks.

Thank you phillipp. I have done as you advised, also using the information at http://windows.microsoft.com/en-GB/windows-live/family-safety-remove-uninstall-faq, I have removed my self from family safety. I am the only user of the pc. Then I restarted. Annoyingly I still have the same problem, Error code: sec_error_bad_signature, when I tried www.google.co.uk for example. Interestingly, I get the amazon home page coming up at www.amazon.co.uk, but when I try to sign in I get the error message. Also the www.bbc.co.uk website is fine. Could it be something to do with https ? Many thanks.
Rob 0 solutions 4 answers

Do you happen to be an Avast anti-virus user? Our QA engineers have been seeing an issue with certain Avast configurations as detailed in this forum post.

Do you happen to be an Avast anti-virus user? Our QA engineers have been seeing an issue with certain Avast configurations as detailed in [https://support.mozilla.org/en-US/questions/1055379 this forum post].
jscher2000
  • Top 10 Contributor
8886 solutions 72700 answers

For some reason, many Windows 10 upgraders are reporting issues with secure sites (often a single site and not others, which is even stranger).

Do you use Avast, BitDefender, ESET or Kaspersky, or any kind of proxy server, or any other product/service which filters your internet access?

For some reason, many Windows 10 upgraders are reporting issues with secure sites (often a single site and not others, which is even stranger). Do you use Avast, BitDefender, ESET or Kaspersky, or any kind of proxy server, or any other product/service which filters your internet access?

Question owner

Thanks Rob and jscher2000. I do have Avast. As a test I turned Avast off, and 'hey presto' firefox https connections to google, gmail and amazon worked as before with no problem. Turn Avast back on and the usual Error code: sec_error_bad_signature returns. Strangely, yesterday was the first time I have ever had a problem, even though there is a history on the Avast forum Rob so kindly pointed out. So it is Avast screwing up my Firefox NOT Windows 10 (but what a coincidence though). I'm not an IT professional, but I think including these URLs in Avast's exception list is a bit of a cop out. I will report the issue to Avast, and all I can hope is they fix the issue asap. Until then I will have to use Chrome browser which has no problems. Many thanks to all that helped me with this problem.

Thanks Rob and jscher2000. I do have Avast. As a test I turned Avast off, and 'hey presto' firefox https connections to google, gmail and amazon worked as before with no problem. Turn Avast back on and the usual Error code: sec_error_bad_signature returns. Strangely, yesterday was the first time I have ever had a problem, even though there is a history on the Avast forum Rob so kindly pointed out. So it is Avast screwing up my Firefox NOT Windows 10 (but what a coincidence though). I'm not an IT professional, but I think including these URLs in Avast's exception list is a bit of a cop out. I will report the issue to Avast, and all I can hope is they fix the issue asap. Until then I will have to use Chrome browser which has no problems. Many thanks to all that helped me with this problem.
philipp
  • Top 25 Contributor
  • Moderator
5346 solutions 23603 answers

Chosen Solution

hey, please disable https scaning within avast:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

hey, please disable https scaning within avast: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok. http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

Helpful Reply

Thank you so very much philipp, you've cracked the problem! Disabling https scanning by Avast is the answer, I am very happy now, once again many thanks!

Thank you so very much philipp, you've cracked the problem! Disabling https scanning by Avast is the answer, I am very happy now, once again many thanks!