Search Support

A link loads automatically when press New Tab ( + ) button. How to replace it with blank page?

  • 11 replies
  • 2 have this problem
  • 32 views
  • Last reply by cor-el

more options

Hi

A link automatically loads up when i click New Tab. I require a blank page or speed dials when i click New Tab. I checked my programs section in control panel & nothing as such is installed. I did re-install firefox but the same issue pops up. Support required here. 

Thanks

All Replies (11)

more options

Type about:config in the address bar, press Enter and accept the warning.

Search browser.newtab.url, double-click on the value (which should be the address of the undesirable site) and replace it by about:blank.

Finally close the tab. It should work.

more options

Hi

This helps but there is another issue with my startup. When i open mozilla, it opens up a link directly though it set to about:home in the same about:config url. I have blocked the site with an add-on but its frustrating that my homepage is not shown at startup.

Thanks

more options

Is it the following parameter you checked in about:config ? browser.startup.homepage

What is its value?

more options

Yes. Its value is about:home. but it still loads up a link.

more options

Maybe an add-on is involved.

You could try to start Firefox in Safe Mode (= with add-ons disabled): click on menu button upper right, click on button ? then Restart with Add-ons Disabled….

more options

Well it doesn't help still. I need to do this whenever the firefox is opened. I require my homepage whenever i start firefox.

more options

Of course, but it was only to check if an add-on set differently the start page (and to disable it if necessary).

Otherwise, you could check if configuration file is properly setted.

  1. Open Notepad (or equivalent)
  2. Open the file prefs.js in the following directory: C:\Users\<user_name>\AppData\Mozilla\Firefox\Profiles\<profile_name>.default
    (replace <…> by your own values)
  3. Find the line starting with user_pref("browser.startup.homepage"
  4. Check the value following the comma
    • If it is about:home, nothing to do*
    • If it is another value, replace it with about:home

*and make more likely one of installed add-ons is at stake

more options

Yes it set to about:home, still it opens that link. I have blocked it with blocksite but its annoying.

more options

At present, the only thing I think that you could do is to follow instructions in this article: Test for faulty extensions.

more options

Hi, sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus built-in already.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Note that not all programs will detect all malware, so you may need to run several or all of them.


After removal, to reset your New Tab to blank, you may need to type about:config into the address bar, press Enter, accept the warning, scroll down to browser.newtab.url and make sure 'Value' is set to about:blank (right click > Modify, to change it if necessary, taking care not to alter anything else). You may then need to restart Firefox.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

If you are still having problems, can you give the URL and/or name of the link in question?

Did this fix your problems? Please report back to us!

more options

Do you find this link on the about:config page when you searched for it?

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

If you do not keep changes after a restart or otherwise have problems with preferences, see: