Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook displays list only

  • 8 replies
  • 64 have this problem
  • 1837 views
  • Last reply by cor-el

more options

Some time recently, Facebook started displaying in text-only list form. (I use Facebook infrequently, so can't say with which version of Firefox this started [I'm now using 39]).

The same thing happens when I try to go to Facebook with IE. There, however, I have a message at the bottom: "Internet Explorer blocked this website from displaying content with security certificate errors." If I click the "Show content" button beside that message, Facebook appears correctly for the remainder of that session, then reverts to the text-only form the next time I try to go there.

For info: (1) I type "http://www.facebook.com", which gets converted to "https ..." (2) I'm not having this problem anywhere else.

Help, please.

Chosen solution

Maybe Kaspersky has updated and fixed this issue for the current Firefox release.

Read this answer in context 👍 15

All Replies (8)

more options

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero).

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate.

more options

Sorry, you lost me when you mentioned "Web Developer."

As best I can understand your advice, you're suggesting I check to see whether Facebook is presenting a valid certificate owned by Facebook? I really doubt that's the problem -- if it were, millions of Facebook users would be bombarding help sites everywhere to demand a fix.

more options

Firefox connects by default via a secure HTTPS connection to Facebook

What security (anti-virus) software do you have?

Some firewalls monitor (secure) connections and send their own certificate instead of the website's certificate. This causes Firefox to show an untrusted message because Firefox can't resolve the certificate chain to a built-in root certificate. You would have to install the root certificate of your security software to stop this error message.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to check this.

more options

I'm using Kaspersky, which very well may be involved in this problem.

In any case, Facebook isn't worth fiddling with root certificates or anything else. On the rare occasions when I'm forced to go to Facebook, I'll just use IE and the "Show content" button it provides to work around this problem when I see IE's "Internet Explorer blocked this website from displaying content with security certificate errors." (But then I have to wonder: Why doesn't Firefox provide a similar informative message and a helpful button that allows me to override the problem?)

Thanks for your help and advice, cor-el.

more options

You can import the Kaspersky root certificate in the Certificate Manager under the Authorities tab.

You can find the "Kaspersky Anti-Virus Personal Root Certificate" in this folder:

  • "C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\"

Set the "Trust this CA to identify websites" trust bit to make the imported certificate work as trusted root certificate to trust websites.

See also: Safe Money security certificate problem - Kaspersky Lab Forum:

Modified by cor-el

more options

Nope, that doesn't do it -- the Kaspersky root certificate is there already, with the "trust" box checked.

more options

News flash: Just checked Facebook, and it appears fine. The problem I had has been there for a few weeks. I post a question here -- and don't change anything on my computer. And then Facebooks again looks the way it's supposed to. Go figure!

more options

Chosen Solution

Maybe Kaspersky has updated and fixed this issue for the current Firefox release.