Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is buggy, google maps won't load, doesnt load company website correctly, unistall&reinstall no help

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options


I have multiple problems with Firefox. - We have just launched a new company website. Our company website shows incorrectly on my screen. When I load the website on Firefox on other computers in the office, the same errors do not occur. If you visit our website and go to the footer of the site and choose any of the tours we operate, the "arrows" on the tour page when they load on my Firefox have jagged edges. They shouldn't have jagged edges. - staying with the display of our new website. On the tour page there is a tab for "dates/rates" when displayed on Firefox on my computer the text is wrapped. On anyone ' computers in our office the text is not wrapped and the text should not be wrapped. This only happens on my computer. It also only happens for our "accommodated adventures (red)", "camping tours (green)" and "expeditions (yellow)". Our "classic tours (blue)" display correctly The two errors above do not occur in Chrome, IE or Firefox on colleagues computers. Only mine. - Google maps doesn't work. Everytime I open google maps the screen freezes and I have to shut down firefox - I have uninstalled Firefox and deleted any file connected to it off my computer. I then reinstalled and my exact same firefox with all my bookmarks etc loaded...? I thought if I uninstalled it would get rid of it completely and I could start again fresh.

I love Firefox in my opinion it is the safest browser to use and picks up issues the fastes, I don't want to use chrome or god forbid Internet Explorer.

Please help.

Thanks Jayne

edit: removed phone # and email from public so as to limit spambots from finding them. Nobody here will phone or email such posted in public.

Attached screenshots

Modified by James

All Replies (2)

more options
more options

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Make sure that you do not run Firefox in compatibility mode or with reduced screen dimensions. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.