X
Tap here to go to the mobile version of the site.

Support Forum

How to stop FF interrumping my sites by preventing other sites from appearing on the screens I browse?

Posted

[Dell Inspiron 560 desktop; MS Windows 7 Home Premium SP1 64bit; Windows Live Mail 2012; MS Word Pro 2003; Mozilla Firefox 22.0]

Please someone tell me how to get rid of that strip across the top of my screen which says something like: Firefox has prevented a site to appear (or something to this effect) and at the right upper corner it says "Allow". Please please I don't want to read that and I don't want to have to go to that right upper corner to click on it all the time.

This is extremely annoying and do hope it can be stopped. Thanks ever so very much for any help.  :o) Adela

P.S. I previously sent an appeal for help because I want to also get rid of 2 annoying FF doing (but forgot to enter my data):

1. Stop putting that password-window which I have to bother deleting all the time; and 2. Stop showing those open windows I keep in my taskbar which keep covering the sight of where I work on.

[Dell Inspiron 560 desktop; MS Windows 7 Home Premium SP1 64bit; Windows Live Mail 2012; MS Word Pro 2003; Mozilla Firefox 22.0] Please someone tell me how to get rid of that strip across the top of my screen which says something like: Firefox has prevented a site to appear (or something to this effect) and at the right upper corner it says "Allow". Please please I don't want to read that and I don't want to have to go to that right upper corner to click on it all the time. This is extremely annoying and do hope it can be stopped. Thanks ever so very much for any help. :o) Adela P.S. I previously sent an appeal for help because I want to also get rid of 2 annoying FF doing (but forgot to enter my data): 1. Stop putting that password-window which I have to bother deleting all the time; and 2. Stop showing those open windows I keep in my taskbar which keep covering the sight of where I work on.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Coupons, Inc. Coupon Printer 5.0.2.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Helpful Reply

Does the message say that Firefox prevented the site from redirecting? In that case, you might have accidentally turned on an accessibility feature designed to avoid confusion for users with screen reader software. You can switch it off here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General mini-tab

In the top section, uncheck the box for "Warn me when websites try to redirect or reload the page"

Does that fix it?

Adelaa said

P.S. I previously sent an appeal for help because I want to also get rid of 2 annoying FF doing (but forgot to enter my data):

1. Stop putting that password-window which I have to bother deleting all the time; and
2. Stop showing those open windows I keep in my taskbar which keep covering the sight of where I work on.

I think #1 is addressed in this solved thread: How to get rid of a popup offering to remember my password appearing at the upper left corner? If there any new developments with that problem, you might follow up there on those so the complete context is apparent. Or if it's still fixed, then never mind.

I don't understand #2. Is the Windows taskbar overlapping the Firefox window, blocking part of the page?? It would help if you could describe this problem in more detail.

Does the message say that Firefox prevented the site from redirecting? In that case, you might have accidentally turned on an accessibility feature designed to avoid confusion for users with screen reader software. You can switch it off here: "3-bar" menu button (or Tools menu) > Options > Advanced > General mini-tab In the top section, ''uncheck'' the box for "Warn me when websites try to redirect or reload the page" Does that fix it? ''Adelaa [[#question-1071954|said]]'' <blockquote> P.S. I previously sent an appeal for help because I want to also get rid of 2 annoying FF doing (but forgot to enter my data):<br><br> 1. Stop putting that password-window which I have to bother deleting all the time; and<br> 2. Stop showing those open windows I keep in my taskbar which keep covering the sight of where I work on. </blockquote> I think #1 is addressed in this solved thread: [https://support.mozilla.org/questions/1056685 How to get rid of a popup offering to remember my password appearing at the upper left corner?] If there any new developments with that problem, you might follow up there on those so the complete context is apparent. Or if it's still fixed, then never mind. I don't understand #2. Is the Windows taskbar overlapping the Firefox window, blocking part of the page?? It would help if you could describe this problem in more detail.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Question owner

Thank you jscher. I did go to the General Mini Tab but, I didn't see this item: "Warn me when websites try to redirect or reload the page" even though I searched all over in all the other side tabs too, etc.

No. 2: When I have a few open files in the taskbar, a reflection of these open files erect themselves above my files each time my cursor touches accidentally any of them, thereby covering much of the screen. True they don't last but it is a pain. If there's a way to rid them I'll appreciate knowing it. They are a mini reflection of the file page from those files in the taskbar. If I have say, 3 or 4 of them, they take up almost one third of the screen. You don't have these? Perhaps I'll send you a screenshot?

I'll go now to see the link you so kindly sent me and see fi I can get rid of some of the other FF's things. lol! Thanks again!  :o)

Thank you jscher. I did go to the General Mini Tab but, I didn't see this item: "Warn me when websites try to redirect or reload the page" even though I searched all over in all the other side tabs too, etc. No. 2: When I have a few open files in the taskbar, a reflection of these open files erect themselves above my files each time my cursor touches accidentally any of them, thereby covering much of the screen. True they don't last but it is a pain. If there's a way to rid them I'll appreciate knowing it. They are a mini reflection of the file page from those files in the taskbar. If I have say, 3 or 4 of them, they take up almost one third of the screen. You don't have these? Perhaps I'll send you a screenshot? I'll go now to see the link you so kindly sent me and see fi I can get rid of some of the other FF's things. lol! Thanks again! :o)

Question owner

Hello and thank you. I do scan with different programs every other day and it never finds anything other than innocent cookies, etc. and they're promptly deleted.

I agree with you that using different programs is better than just one or 2 which I'm subscribed to. I use the avar! AV and it even catches infected messages before I open them.

However, I'll go and read the link you gave me for which thanks again!  :o)

Hello and thank you. I do scan with different programs every other day and it never finds anything other than innocent cookies, etc. and they're promptly deleted. I agree with you that using different programs is better than just one or 2 which I'm subscribed to. I use the avar! AV and it even catches infected messages before I open them. However, I'll go and read the link you gave me for which thanks again! :o)
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

The setting you're looking for is in the Advanced panel of the Options page -- click Advanced in the left column. On the Advanced panel, you should find several mini-tabs at the top, the first one should be General.

If it's still not there, you can use the about:config preferences editor to change the setting if needed. That's a lot of typing, so I'll hold off on those steps unless needed.


Regarding the Task Bar, are those the same kinds of thumbnail images you get for all running Windows applications? That is part of using the Aero themes (http://windows.microsoft.com/en-us/wi.../what-is-the-aero-desktop-experience) and I couldn't quickly find an easy way to disable it.

Two things might help:

(1) Only show individual Firefox windows as thumbnails and not every open tab. To check that, return to the Options screen, General panel (the one where you set the Startup options). Under "Tabs", uncheck "Show tab previews in the Windows taskbar" if it's turned on.

(2) Try Firefox's full screen view. If you press F11, Firefox should expand to fill the whole screen, hiding the Windows Taskbar. It also hides the toolbar area so to be able to work with that, slide the mouse to the top of the screen and pause while Firefox pulls the toolbars back down. Right-click a blank area of the tab bar and uncheck the Hide Toolbars option.

The setting you're looking for is in the Advanced panel of the Options page -- click Advanced in the left column. On the Advanced panel, you should find several mini-tabs at the top, the first one should be General. If it's still not there, you can use the about:config preferences editor to change the setting if needed. That's a lot of typing, so I'll hold off on those steps unless needed. ---- Regarding the Task Bar, are those the same kinds of thumbnail images you get for all running Windows applications? That is part of using the Aero themes ([http://windows.microsoft.com/en-us/windows7/what-is-the-aero-desktop-experience]) and I couldn't quickly find an easy way to disable it. Two things might help: (1) Only show individual Firefox windows as thumbnails and not every open tab. To check that, return to the Options screen, General panel (the one where you set the Startup options). Under "Tabs", ''uncheck'' "Show tab previews in the Windows taskbar" if it's turned on. (2) Try Firefox's full screen view. If you press F11, Firefox should expand to fill the whole screen, hiding the Windows Taskbar. It also hides the toolbar area so to be able to work with that, slide the mouse to the top of the screen and pause while Firefox pulls the toolbars back down. Right-click a blank area of the tab bar and ''uncheck'' the Hide Toolbars option.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Adelaa said

I did go to the General Mini Tab but, I didn't see this item: Warn me when websites try to redirect or reload the page

Type about:preferences#general<enter> in the address bar.

"Warn me when websites" should be the third item down.

''Adelaa [[#answer-753084|said]]'' <blockquote> I did go to the General Mini Tab but, I didn't see this item: Warn me when websites try to redirect or reload the page </blockquote> Type '''about:preferences#general'''<enter> in the address bar. "Warn me when websites" should be the third item down.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

FredMcD said

Type about:preferences#general<enter> in the address bar. "Warn me when websites" should be the third item down.

Opps . . . . Sorry . . . This should be about:preferences#advanced<enter> Then select General

''FredMcD [[#answer-753110|said]]'' <blockquote> Type '''about:preferences#general'''<enter> in the address bar. "Warn me when websites" should be the third item down. </blockquote> Opps . . . . Sorry . . . This should be '''about:preferences#advanced'''<enter> Then select '''General'''

Question owner

"Advanced panel of the Options page -- click Advanced in the left column."

Oh I found it! I don't know why I didn't see it before, but....it was already unchecked.

As to the aero theme link, no...it isn't it but I see it's in the Win10 and I have Win7. I tried to make a screenshot but because they popout as quickly as they popup...I couldn't! Perhaps one has to have the email client WLMail to see these reflections of my taskbar files, and maybe it's not FF that creates such thing? I may have to go to the WLMail forum about it.

I'll try the paragraphs 1 and 2 you gave me when I return as I have to leave now. Thanks so much I'm learning about all this machine's entrails while following your good instructions. lol!

"Advanced panel of the Options page -- click Advanced in the left column." Oh I found it! I don't know why I didn't see it before, but....it was already unchecked. As to the aero theme link, no...it isn't it but I see it's in the Win10 and I have Win7. I tried to make a screenshot but because they popout as quickly as they popup...I couldn't! Perhaps one has to have the email client WLMail to see these reflections of my taskbar files, and maybe it's not FF that creates such thing? I may have to go to the WLMail forum about it. I'll try the paragraphs 1 and 2 you gave me when I return as I have to leave now. Thanks so much I'm learning about all this machine's entrails while following your good instructions. lol!

Question owner

"This should be about:preferences#advanced<enter> Then select General"

Thank you Fred, I did and found it. It provided me with a 2nd way to get to the same place, but as I mentioned to Jscher, it was unchecked.

thanks again, I'm learning hi tech here!  :) Rosedala

"This should be about:preferences#advanced<enter> Then select General" Thank you Fred, I did and found it. It provided me with a 2nd way to get to the same place, but as I mentioned to Jscher, it was unchecked. thanks again, I'm learning hi tech here! :) Rosedala
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Okay, next time you see the message, could you make a note of the exact language? For example, does it mention blocking pop-ups?

Okay, next time you see the message, could you make a note of the exact language? For example, does it mention blocking pop-ups?

Question owner

Thank you very much, yes, one of them is as follows:

"FF has prevented the outdated plugin "Adobe Flash" from running on www.adobeflash.com". Then 2 buttons:

"Continue blocking" and "Allow"

On clicking Allow it takes me to another small window at the upper left corner repeating the above. Clicking on this, it takes me to the Adobe Flash windows urging to download...which I don't have to since I have this program for sometime now and routinely updated.

I hope there is a way to get rid of these time consuming nonsense ads, apparently done in partnership between Firefox and Adobe. Are they owned by the same co. maybe? It's still terribly annoying.

As to the other problems, I'm working on them.

Thank you very much, yes, one of them is as follows: "FF has prevented the outdated plugin "Adobe Flash" from running on www.adobeflash.com". Then 2 buttons: "Continue blocking" and "Allow" On clicking Allow it takes me to another small window at the upper left corner repeating the above. Clicking on this, it takes me to the Adobe Flash windows urging to download...which I don't have to since I have this program for sometime now and routinely updated. I hope there is a way to get rid of these time consuming nonsense ads, apparently done in partnership between Firefox and Adobe. Are they owned by the same co. maybe? It's still terribly annoying. As to the other problems, I'm working on them.

Modified by Adelaa

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Security Issue: Update your Flash Player Version 18.0.0.209
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Security Issue: Update your Flash Player '''Version 18.0.0.209<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Internet Explorer” '''and''' “Plugin-based browsers” installers. See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Hi Adelaa, thank you for the additional detail.

Due to a confessed vulnerability in version 18.0.0.203 of the Flash plugin, Mozilla had soft-blocked it. When a plugin is soft-blocked, you can still use it by activating it on sites you trust, but Firefox will not activate it automatically.

I'm speaking in the past tense because Adobe released an update a couple days ago to resolve the critical issues in 18.0.0.203. You can get 18.0.0.209 on this page:

https://www.adobe.com/products/flashplayer/distribution3.html

In the first table, look for the row for "plugin-based browsers" and you can use either the EXE or the MSI installer.

To ensure that the installer can remove the old version, please close any tabs that are using Flash, or exit out of Firefox, while updating Flash.


No one can promise that this kind of block will never happen again. Should that occur, if you are not accustomed to using the "Ask to Activate" feature for a plugin, here's what to expect:

When you visit a site that wants to use Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the Lego-like icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want it later.

Hi Adelaa, thank you for the additional detail. Due to a confessed vulnerability in version 18.0.0.203 of the Flash plugin, Mozilla had soft-blocked it. When a plugin is soft-blocked, you can still use it by activating it on sites you trust, but Firefox will not activate it automatically. I'm speaking in the past tense because Adobe released an update a couple days ago to resolve the critical issues in 18.0.0.203. You can get 18.0.0.209 on this page: https://www.adobe.com/products/flashplayer/distribution3.html In the first table, look for the row for "plugin-based browsers" and you can use either the EXE or the MSI installer. To ensure that the installer can remove the old version, please close any tabs that are using Flash, or exit out of Firefox, while updating Flash. ---- No one can promise that this kind of block will never happen again. Should that occur, if you are not accustomed to using the "Ask to Activate" feature for a plugin, here's what to expect: When you visit a site that wants to use Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the Lego-like icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want it later.

Question owner

Thank you Fred. I'm still confused as to why FF meddles in the Adobe problems, but I had Adobe Flash for years and only recently it asks often, by emails, to download. I comply each time and it shows Version 18 NPAPI in my Control Panel. I even downloaded it now again on the link you gave me and it still shows the same version number...do you know what 18 NPAPI may mean instead of showing "18.0.0.209"?

Anyway, I don't know if my computer has a graphics card, and I will go and try to find out. Thank you again.

Thank you Fred. I'm still confused as to why FF meddles in the Adobe problems, but I had Adobe Flash for years and only recently it asks often, by emails, to download. I comply each time and it shows Version 18 NPAPI in my Control Panel. I even downloaded it now again on the link you gave me and it still shows the same version number...do you know what 18 NPAPI may mean instead of showing "18.0.0.209"? Anyway, I don't know if my computer has a graphics card, and I will go and try to find out. Thank you again.
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

NPAPI stands for Netscape Plugin API (API = Application Programming Interface)

To see the version Firefox is using, you can check the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, look for "Shockwave Flash".


Also, emails? I would not expect to get emails from Adobe about Flash updates because they don't collect my email address when I install. Did you subscribe to that service in some other way?

NPAPI stands for Netscape Plugin API (API = Application Programming Interface) To see the version Firefox is using, you can check the Add-ons page. Either: * Ctrl+Shift+a (Mac: Cmd+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, look for "Shockwave Flash". ---- Also, emails? I would not expect to get emails from Adobe about Flash updates because they don't collect my email address when I install. Did you subscribe to that service in some other way?

Question owner

Hello jscher and thank you,

"When a plugin is soft-blocked, you can still use it by activating it on sites you trust, but Firefox will not activate it automatically." (What happened to the Quotes icon?)

To activate it automatically do I go to Firefox somewhere?

"To ensure that the installer can remove the old version, please close any tabs that are using Flash, or exit out of Firefox, while updating Flash."

Maybe I may not have done this, so I'll try it again by downloading Adobe away from Firefox.

"When you visit a site that wants to use Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page."

I've never seen this before. Do you think then that if I use "Ask to Activate" it will help to try to do away with FF decisions?

I'm sorry to be so ignorant of these details, but at least now I know that I must learn to live with the Firefox authority to interfere....

Thanks again.  :)

Hello jscher and thank you, "When a plugin is soft-blocked, you can still use it by activating it on sites you trust, but Firefox will not activate it automatically." (What happened to the Quotes icon?) To activate it automatically do I go to Firefox somewhere? "To ensure that the installer can remove the old version, please close any tabs that are using Flash, or exit out of Firefox, while updating Flash." Maybe I may not have done this, so I'll try it again by downloading Adobe away from Firefox. "When you visit a site that wants to use Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page." I've never seen this before. Do you think then that if I use "Ask to Activate" it will help to try to do away with FF decisions? I'm sorry to be so ignorant of these details, but at least now I know that I must learn to live with the Firefox authority to interfere.... Thanks again. :)
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Hi Adelaa, I personally keep Flash set to "Ask to Activate" at all times because many sites use Flash only to annoy you, or to track you. So while this is an unfamiliar arrangement for many people, to me, it's completely normal.

You can choose to have a plugin set to "Always Activate" except when the plugin is blocked which is a security-related situation. It's very rare that the latest version of a plugin would be blocked. Other than the Java Deployment Toolkit, which is used very rarely on the web, I can't recall it happening before. If Adobe is swift with updates, then hopefully it can be avoided in the future as well.

Hi Adelaa, I personally keep Flash set to "Ask to Activate" at all times because many sites use Flash only to annoy you, or to track you. So while this is an unfamiliar arrangement for many people, to me, it's completely normal. You can choose to have a plugin set to "Always Activate" ''except when the plugin is blocked'' which is a security-related situation. It's very rare that the latest version of a plugin would be blocked. Other than the Java Deployment Toolkit, which is used very rarely on the web, I can't recall it happening before. If Adobe is swift with updates, then hopefully it can be avoided in the future as well.

Question owner

jscher2000 said

NPAPI stands for Netscape Plugin API (API = Application Programming Interface) To see the version Firefox is using, you can check the Add-ons page. Either:
  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. On the right side, look for "Shockwave Flash".

Also, emails? I would not expect to get emails from Adobe about Flash updates because they don't collect my email address when I install. Did you subscribe to that service in some other way?

Oh so the version number I have came from Adobe? Is it better then to have the Firefox version #? If so, thanks for telling me how to get it.

Yes, I get frequent emails from Adobe urging me to update (maybe they are phishing?). Because I suspect, I delete them and I usually go to their site to update it. As to having subscribed to them...I don't remember. I guest I must have otherwise they couldn't email me?

(Goodness! The things one does when moving in unknown tech worlds! When I acquired my computer for the first time all I wanted was emailing and searching and it was good and no problems....but it seems now that it exploded into what I see like infinite dark labyrinths to me... lol! )

''jscher2000 [[#answer-754781|said]]'' <blockquote> NPAPI stands for Netscape Plugin API (API = Application Programming Interface) To see the version Firefox is using, you can check the Add-ons page. Either: * Ctrl+Shift+a (Mac: Cmd+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, look for "Shockwave Flash". ---- Also, emails? I would not expect to get emails from Adobe about Flash updates because they don't collect my email address when I install. Did you subscribe to that service in some other way? </blockquote> Oh so the version number I have came from Adobe? Is it better then to have the Firefox version #? If so, thanks for telling me how to get it. Yes, I get frequent emails from Adobe urging me to update (maybe they are phishing?). Because I suspect, I delete them and I usually go to their site to update it. As to having subscribed to them...I don't remember. I guest I must have otherwise they couldn't email me? (Goodness! The things one does when moving in unknown tech worlds! When I acquired my computer for the first time all I wanted was emailing and searching and it was good and no problems....but it seems now that it exploded into what I see like infinite dark labyrinths to me... lol! )
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Mozilla doesn't redistribute the Flash plugin, so you should always get it from Adobe one way or the other (whether you get forwarded there by the Mozilla plugin checker site or if you go there directly).

Mozilla doesn't redistribute the Flash plugin, so you should always get it from Adobe one way or the other (whether you get forwarded there by the Mozilla plugin checker site or if you go there directly).

Question owner

jscher2000 said

Hi Adelaa, I personally keep Flash set to "Ask to Activate" at all times because many sites use Flash only to annoy you, or to track you. So while this is an unfamiliar arrangement for many people, to me, it's completely normal. You can choose to have a plugin set to "Always Activate" except when the plugin is blocked which is a security-related situation. It's very rare that the latest version of a plugin would be blocked. Other than the Java Deployment Toolkit, which is used very rarely on the web, I can't recall it happening before. If Adobe is swift with updates, then hopefully it can be avoided in the future as well.

Could you please tell me how to get this "Always Activate" function? And is it in Firefox or Adobe?

Thank you!

''jscher2000 [[#answer-754789|said]]'' <blockquote> Hi Adelaa, I personally keep Flash set to "Ask to Activate" at all times because many sites use Flash only to annoy you, or to track you. So while this is an unfamiliar arrangement for many people, to me, it's completely normal. You can choose to have a plugin set to "Always Activate" ''except when the plugin is blocked'' which is a security-related situation. It's very rare that the latest version of a plugin would be blocked. Other than the Java Deployment Toolkit, which is used very rarely on the web, I can't recall it happening before. If Adobe is swift with updates, then hopefully it can be avoided in the future as well. </blockquote> Could you please tell me how to get this "Always Activate" function? And is it in Firefox or Adobe? Thank you!