X
Tap here to go to the mobile version of the site.

Support Forum

Only in Firefox brower I get blank areas in AT&T/Yahoo news page and when writing emails.

Posted

This is an ongoing problem for several months, I have already tried clearing cookies and cache, restarting Firefox in safe mode, deleting all plugins, reinstalling Firefox. None of this had any effect. I have gone back to using Internet Explorer which does not have this problem, even though I like Firefox better. This problem also does NOT happen in Chrome browser. Only in Firefox.

This is an ongoing problem for several months, I have already tried clearing cookies and cache, restarting Firefox in safe mode, deleting all plugins, reinstalling Firefox. None of this had any effect. I have gone back to using Internet Explorer which does not have this problem, even though I like Firefox better. This problem also does NOT happen in Chrome browser. Only in Firefox.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; InfoPath.3; MDDCJS; rv:11.0) like Gecko

More Information

FredMcD
  • Top 10 Contributor
4258 solutions 59626 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you! ---------------------- Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' ------------------ If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Could you also test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

Could you also test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any difference?

Question owner

Thanks for trying to help me with this. I've tried twice to upload my screen shot showing the blank are in AT&T/Yahoo news page; however, it just keeps spinning around in the Upload images box. I saved is as png, as directed. So, I seem to be stuck.

Thanks for trying to help me with this. I've tried twice to upload my screen shot showing the blank are in AT&T/Yahoo news page; however, it just keeps spinning around in the Upload images box. I saved is as png, as directed. So, I seem to be stuck.

Question owner

I did try opening Firefox in safe mode; however, that seemed to make no difference.

I did try opening Firefox in safe mode; however, that seemed to make no difference.

Question owner

Here we go. I tried again with a different screen shot (this one of an email with a small blanked out area. I hope this is a help. Thanks!

Here we go. I tried again with a different screen shot (this one of an email with a small blanked out area. I hope this is a help. Thanks!

Question owner

There I had to reduce the size to get the screen shot of the news page with a blank area to load. I hope someone can figure out why it does this only in Firefox.

There I had to reduce the size to get the screen shot of the news page with a blank area to load. I hope someone can figure out why it does this only in Firefox.
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

That's odd, it's as though there are white rectangles overload on the page. If you right-click one of those areas and choose Inspect Element (Q), Firefox should display a panel in the lower part of the tab with the right-clicked element selected. Is it the paragraph with the actual content in it, or something floating in front?

That's odd, it's as though there are white rectangles overload on the page. If you right-click one of those areas and choose Inspect Element (Q), Firefox should display a panel in the lower part of the tab with the right-clicked element selected. Is it the paragraph with the actual content in it, or something floating in front?
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

You mentioned scrolling can correct the problem. How about forcing repainting with a zoom level change, such as Ctrl+ followed by Ctrl- (zoom in - zoom out)?

If that helps, you could try disabling OMTC, a feature introduced in Firefox 33. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false

Note: I read in a bug report that this change causes problems with the HTML5 player on YouTube, if hardware acceleration is disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

You also could check for updates to your display driver software to enable some newer capabilities: Upgrade your graphics drivers to use hardware acceleration and WebGL.

You mentioned scrolling can correct the problem. How about forcing repainting with a zoom level change, such as Ctrl+ followed by Ctrl- (zoom in - zoom out)? If that helps, you could try disabling OMTC, a feature introduced in Firefox 33. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''layers''' and pause while the list is filtered (3) Double-click the '''layers.offmainthreadcomposition.enabled''' preference to switch it from true to false Note: I read in a bug report that this change causes problems with the HTML5 player on YouTube, if hardware acceleration is disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ You also could check for updates to your display driver software to enable some newer capabilities: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]].
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158559 answers

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages ----- If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems. *Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none) Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

Question owner

This is a screen shot of the inspector element. I have no idea what it means.

This is a screen shot of the inspector element. I have no idea what it means.
jscher2000
  • Top 10 Contributor
8767 solutions 71704 answers

Hi alhenegar, the element with the selection bar in your screen shot of the Inspector is something way in the background rather than any specific thing in the mail message you are reading. So that doesn't point to a solution, unfortunately.

Edit: Added screenshot with the "shellinner" element highlighted, it's the container of the entire message area.

Hi alhenegar, the element with the selection bar in your screen shot of the Inspector is something way in the background rather than any specific thing in the mail message you are reading. So that doesn't point to a solution, unfortunately. Edit: Added screenshot with the "shellinner" element highlighted, it's the container of the entire message area.

Modified by jscher2000

Question owner

Hi jscher, Thanks for checking that out for me. I guess I will continue looking for an answer.

Hi jscher, Thanks for checking that out for me. I guess I will continue looking for an answer.

Question owner

Hi Cor-el, I checked on my advanced setting using your very helpful instruction and I have evidently made no advanced setting (probably because I had no idea how to do so). So, Default Font is "16", Minimum Font Size is "none" and I have a check mark in the "Allow pages to choose their own fonts, instead of my selections above". Thank you for trying to help. As you can, no doubt, tell I am lost in all this area.

Hi Cor-el, I checked on my advanced setting using your very helpful instruction and I have evidently made no advanced setting (probably because I had no idea how to do so). So, Default Font is "16", Minimum Font Size is "none" and I have a check mark in the "Allow pages to choose their own fonts, instead of my selections above". Thank you for trying to help. As you can, no doubt, tell I am lost in all this area.

Question owner

Hi jscher 2000, I tried your idea to set layers.offmainthreadcomposition.enabled to false, but this didn't seem to help, so I switched it back to true. This is sure a puzzle to me.

Hi jscher 2000, I tried your idea to set layers.offmainthreadcomposition.enabled to false, but this didn't seem to help, so I switched it back to true. This is sure a puzzle to me.
FredMcD
  • Top 10 Contributor
4258 solutions 59626 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart. --------------------- '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Question owner

Hi FredMcD, As I wrote in my opening post, I have already tried clearing ALL cookies and cache, restarting Firefox in safe mode, deleting all plugins, reinstalling Firefox. None of this had any effect. I also ran virus scan. I tried it after all these steps and still continued to have the blanked out areas. Most of the time the text is just blanked out in random shaped blocks, but sometimes the blanked out area is solid black. Of course, I have no idea why that would be the case. It seems to me that if it was something to do with my computer itself that I would have this same issue on Internet Explorer and Chrome, but I don't. Those seem to work fine with no blanked out areas.

Hi FredMcD, As I wrote in my opening post, I have already tried clearing ALL cookies and cache, restarting Firefox in safe mode, deleting all plugins, reinstalling Firefox. None of this had any effect. I also ran virus scan. I tried it after all these steps and still continued to have the blanked out areas. Most of the time the text is just blanked out in random shaped blocks, but sometimes the blanked out area is solid black. Of course, I have no idea why that would be the case. It seems to me that if it was something to do with my computer itself that I would have this same issue on Internet Explorer and Chrome, but I don't. Those seem to work fine with no blanked out areas.
FredMcD
  • Top 10 Contributor
4258 solutions 59626 answers

alhenegar said

Hi FredMcD, As I wrote in my opening post, I have already tried clearing ALL cookies and cache, restarting Firefox in safe mode, deleting all plugins . . . .

Plugins like Java, Flash and others are what display the page for special items.

Use this link and reinstall the current plugins. https://support.mozilla.org/en-US/forums/support-forum-contributors/711401

''alhenegar [[#answer-753893|said]]'' <blockquote> Hi FredMcD, As I wrote in my opening post, I have already tried clearing ALL cookies and cache, restarting Firefox in safe mode, deleting all plugins''' . . . .''' </blockquote> Plugins like Java, Flash and others are what display the page for special items. Use this link and reinstall the current plugins. https://support.mozilla.org/en-US/forums/support-forum-contributors/711401

Question owner

Hi FredMcD, Yes, I did have to reinstall all those plugins again. That's why I don't want to try those steps again. It's kind of a mess to put everything back together.

Hi FredMcD, Yes, I did have to reinstall all those plugins again. That's why I don't want to try those steps again. It's kind of a mess to put everything back together.