Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

While installing software I forgot to uncheck to change my start page and now it goes to hi.ru even though I have changed it back in Firefox.

  • 1 reply
  • 1 has this problem
  • 18 views
  • Last reply by jscher2000

more options

I was installing software. I forgot to uncheck checkbox changing my home page. I changed it back in Firefox and it still comes up. The site is hi.ru and not in English. I've checked for any new or unusual software in Control Panel and can see nothing unusual.

Chosen solution

This problem is on your Windows 8.1 system? (Somehow this post got slotted under FirefoxOS, which is for some mobile phones.)

If Firefox is ignoring your home page setting, there are a couple possible scenarios:

(1) An extension is overriding the setting (2) Your desktop icon is "hacked" with the unwanted address (in this case, the home button on the toolbar and Ctrl+n would both work correctly)

As the first step, here's my suggested procedure for tracking down and cleaning up unwanted add-ons. I know it seems long, but it's not that bad.

(A) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

(B) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

If you have some additional time:

(C) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

This problem is on your Windows 8.1 system? (Somehow this post got slotted under FirefoxOS, which is for some mobile phones.)

If Firefox is ignoring your home page setting, there are a couple possible scenarios:

(1) An extension is overriding the setting (2) Your desktop icon is "hacked" with the unwanted address (in this case, the home button on the toolbar and Ctrl+n would both work correctly)

As the first step, here's my suggested procedure for tracking down and cleaning up unwanted add-ons. I know it seems long, but it's not that bad.

(A) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

(B) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

If you have some additional time:

(C) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?