X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox telling me to update Adobe Reader and Flashplayer and Firefox, when I have the latest updates on my laptop?

Posted

I am using windows 8.1. I have the latest versions of Fiirefox, Reader and Flash, but Firefox keeps saying I need to update to the latest version. Why?

I am using windows 8.1. I have the latest versions of Fiirefox, Reader and Flash, but Firefox keeps saying I need to update to the latest version. Why?

Chosen solution

I wouldn't worry about Adobe Reader. If the Help > Check for Updates inside your Reader XI says you are current, as far as I am concerned, that is fine. The Plugin Checker always pushes you to get the newest release, but Adobe is still providing security updates for Reader 11, and since the radically different interface of Reader DC is definitely not going to be everyone's favorite, I think that will continue for quite a while.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 17.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • 5.1.40416.0
  • The plugin allows you to have a better experience with Microsoft Lync
  • iTunes Detector Plug-in
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • NPWLPG
  • WildTangent Games App V2 Presence Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

You are using Firefox 29, Flash 17, and Reader 11. You need to use Firefox 39, Flash 18, and Reader 2015.

You are using Firefox 29, Flash 17, and Reader 11. You need to use Firefox 39, Flash 18, and Reader 2015.

Question owner

eagle654b said

I am using windows 8.1. I have the latest versions of Fiirefox, Reader and Flash, but Firefox keeps saying I need to update to the latest version. Why?

I updated to firefox 39, but adobe says reader 11 is the latest update available for my computer. I also can't find the version for flash.

''eagle654b [[#question-1071137|said]]'' <blockquote> I am using windows 8.1. I have the latest versions of Fiirefox, Reader and Flash, but Firefox keeps saying I need to update to the latest version. Why? </blockquote> I updated to firefox 39, but adobe says reader 11 is the latest update available for my computer. I also can't find the version for flash.
James
  • Moderator
1595 solutions 11242 answers
Get the Flash player (plugin based) from https://www.adobe.com/products/flashplayer/distribution3.html https://get.adobe.com/reader/otherversions/ Reader DC 2015.007.20033

Modified by James

jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Chosen Solution

I wouldn't worry about Adobe Reader. If the Help > Check for Updates inside your Reader XI says you are current, as far as I am concerned, that is fine. The Plugin Checker always pushes you to get the newest release, but Adobe is still providing security updates for Reader 11, and since the radically different interface of Reader DC is definitely not going to be everyone's favorite, I think that will continue for quite a while.

I wouldn't worry about Adobe Reader. If the Help > Check for Updates inside your Reader XI says you are current, as far as I am concerned, that is fine. The Plugin Checker always pushes you to get the newest release, but Adobe is still providing security updates for Reader 11, and since the radically different interface of Reader DC is definitely not going to be everyone's favorite, I think that will continue for quite a while.