X
Tap here to go to the mobile version of the site.

Support Forum

Firefox does not supporting jquery's slick function and showing error as below

Posted

TypeError: $(...).slick is not a function

TypeError: $(...).slick is not a function

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 38.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0/Linux/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firebug 2.0.11 (firebug@software.joehewitt.com)
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 3.0.2 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2014.07.01.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Haswell Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.5.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Mobile
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Where to go for developer support

Also check what version of jquery you are calling.

[https://support.mozilla.org/en-US/kb/where-go-developer-support Where to go for developer support] Also check what version of jquery you are calling.

Modified by guigs

cor-el
  • Top 10 Contributor
  • Moderator
17414 solutions 157300 answers

You can also try the version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
You can also try the version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

What site has this problem? Slick is a plugin, so perhaps the site has not implemented it correctly.

The demos on this page work for me in Firefox 39 (customized profile, so could differ from yours): http://kenwheeler.github.io/slick/

If that site doesn't work for you either, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

What site has this problem? Slick is a plugin, so perhaps the site has not implemented it correctly. The demos on this page work for me in Firefox 39 (customized profile, so could differ from yours): http://kenwheeler.github.io/slick/ If that site doesn't work for you either, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?