X
Tap here to go to the mobile version of the site.

Support Forum

Firefox never opens the start page i select

Posted

Whenever i close firefox window or quit firefox, it loses my tabs. When i start the browser back up, i am back on start page every time. I have changed the settings for this, but no matter what i set it to, i always get the start page. I have reset my browser, removed all plugins, cleared all data, made sure firefox does not clear data on exit, and even tried removing prefs.js. I am really stumped here. I have tried everything that other people had fix their issue, but they all had dumb problems like a setting not set correctly. None of the other 50 people who asked about this seemed to have the same issue that I am having. I am running MFf 39.0 on 64x osx 10.10.4

Whenever i close firefox window or quit firefox, it loses my tabs. When i start the browser back up, i am back on start page every time. I have changed the settings for this, but no matter what i set it to, i always get the start page. I have reset my browser, removed all plugins, cleared all data, made sure firefox does not clear data on exit, and even tried removing prefs.js. I am really stumped here. I have tried everything that other people had fix their issue, but they all had dumb problems like a setting not set correctly. None of the other 50 people who asked about this seemed to have the same issue that I am having. I am running MFf 39.0 on 64x osx 10.10.4

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.14
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0
  • iPhoto6

Application

  • Firefox 39.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:39.0) Gecko/20100101 Firefox/39.0
  • Support URL: https://support.mozilla.org/1/firefox/39.0/Darwin/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 8a3
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

It sounds like a setting was changed on your new tab page. These changes are usually caused by third-party toolbars or add-ons. I understand that you would like to know how to change it back. Not a problem, please follow the steps below:

  1. In the Location bar, type about:config and press Enter. The "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. Type browser.newtab.url in the search box to find it on the list.
  4. Double-click on browser.newtab.url and type in about:newtab in the window that pops up.

Restart Firefox and open a new tab to make sure the change was made. If there is any issues with plugins please also see: Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Please post back with your results, we are happy to help.

It sounds like a setting was changed on your new tab page. These changes are usually caused by third-party toolbars or add-ons. I understand that you would like to know how to change it back. Not a problem, please follow the steps below: <!--Experiment 1--> # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''' to continue to the about:config page. # Type '''browser.newtab.url''' in the search box to find it on the list. # Double-click on '''browser.newtab.url''' and type in ''about:newtab'' in the window that pops up. Restart Firefox and open a new tab to make sure the change was made. If there is any issues with plugins please also see: [[Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems]] Please post back with your results, we are happy to help.