Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

there is no more clear history when forefox closes button - how do I have firefox not remember history?

  • 6 replies
  • 2 have this problem
  • 377 views
  • Last reply by cpmgmt222

more options

how do I get Firefox to not remember history

Chosen solution

Are you saying that when you use <Control><Shift> H, the history is recorded?

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

The prefs.js file stores customized user preference settings, such as changes you make in Firefox Options dialogs. The optional user.js file, if one exists, will override any modified preferences.


If all else fails;

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the places.sqlite file. Then rename or delete it. Restart Firefox.

Read this answer in context 👍 1

All Replies (6)

more options

Type about:preferences#privacy<enter> in the address bar, and look under History.

more options

To see all History and Cookie settings, choose:

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
more options

I have never remember history checked and firefox still remembers everything... also tried custom setting - same result.

more options

Chosen Solution

Are you saying that when you use <Control><Shift> H, the history is recorded?

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

The prefs.js file stores customized user preference settings, such as changes you make in Firefox Options dialogs. The optional user.js file, if one exists, will override any modified preferences.


If all else fails;

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the places.sqlite file. Then rename or delete it. Restart Firefox.

more options

Note that you still see the cookies and history from normal mode when you are in Private Browsing mode when you check that in the cookie and in the history manager in Private Browsing mode. Only new history shouldn't be created.

more options

to fredMcd - your idea worked.... everything is now OK !!! Thanx a million