Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sync fails with "Failed to connect to server"

  • 7 replies
  • 6 have this problem
  • 50 views
  • Last reply by schnittchen

more options

I have successfully connected to my sync account, yet syncing always fails with the above error message.

I have tried with safe mode. I am not behind a weird prozy.

Also, I noticed https://accounts.firefox.com/settings/communication_preferences never finishes loading (console message "Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://api.accounts.firefox.com/v1/certificate/sign. (Reason: CORS request failed).")

Here is a paste of a failure log: https://pastebin.mozilla.org/8838575 It expires within a day.

I have successfully connected to my sync account, yet syncing always fails with the above error message. I have tried with safe mode. I am not behind a weird prozy. Also, I noticed https://accounts.firefox.com/settings/communication_preferences never finishes loading (console message "Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://api.accounts.firefox.com/v1/certificate/sign. (Reason: CORS request failed).") Here is a paste of a failure log: https://pastebin.mozilla.org/8838575 It expires within a day.

All Replies (7)

more options

Try:

more options

I have an MTU of 1500, so normal.

more options

Synced successfully a few minutes ago, without having any setting changed.

Also, the mentioned CORS problem seems fixed.

more options

Back at home, sync is broken again, and the CORS problem reappeared. What could that be?

more options

I have

  • tried wired network instead of wifi
  • plugging into the cable modem instead of the router that's behind it
  • using google's dns instead of the router's dns proxy thingy

all of which did not work.

more options

With an idea and some googling, I could narrow it down further.

It appears to be this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1118958. I disabled IPv6 and did a

sysctl -w net.ipv4.tcp_mtu_probing=2

and suddenly, sync worked again.

more options

I managed to launch wireshark today and have some conclusions.

With net.ipv4.tcp_mtu_probing=0, tcp packets from my have the don't fragment bit set, and the ICMP fragmentation needed responses I get when trying to sync are ignored.

To me, that sounds like a bug. At the least, net.ipv4.tcp_mtu_probing=1 (which works as well as =2) could be an OS default.

Unsure what's the right way to deal with this...