Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Today when I click on a hyperlink in a gmail message it always opens up the same wrong URL, https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en...

  • 7 replies
  • 6 have this problem
  • 26 views
  • Last reply by thnidu

more options

I was using Firefox 38.something when this started happening, just today. I have since restarted and updated to Ff 39.0, with no change. When I hover the cursor on a hyperlink in Gmail, the pop-up shows the correct URL; I also get the correct URL when I control-click the linked text and click "Copy link location", then paste that into my address bar. But today, whenever I click on a hyperlink directly, I always get the same wrong gmail-internal link:

https://mail.google.com/_/scs/mail-static/_/js/k=gmail.main.en.so9sxCEetKI.O/m=m_i,t,it/am=PiMewvzf-4NYZ5Bd-kjF_v33u0-K3X0e_9-bCJK9Avy_2f8D-D94H30hAQ/rt=h/d=1/t=zcms/rs=AHGWq9D24b9qEWXdzhXaN8poO3SDdT7MnQ

which goes nowhere.

Safari doesn't give me this problem in gmail: it sends me to the right URL.

I am running Mac OS X Lion 10.7.5 (11G63b) on a 13-inch, Mid 2011 MacBook Air with a 1.7 GHz Intel Core i5 processor, 4 GB 1333 MHz DDR3 memory, and Intel HD Graphics 3000 384 MB. (Yes, that's all copy-pasted from "About this Mac".)

All Replies (7)

more options

Ok, this is very strange, can you inspect element on the link and tell me what you see?

more options

It's a blank window, "a perfect and absolute blank". Nothing in the window; all white.

more options

Oh, there are lots of addons... Let's try to start in safe mode.

Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

thnidu said

It's a blank window, "a perfect and absolute blank". Nothing in the window; all white.

By the way, inspect on the link itself (while hovering it), not the blank page.

more options

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

agucova said

By the way, inspect on the link itself (while hovering it), not the blank page.

That's OK. As I said in my original question,

When I hover the cursor on a hyperlink in Gmail, the pop-up shows the correct URL
more options

cor-el said

Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache":
  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

Well, I did that and it didn't help.

"Remove Cookies" from sites causing problems:
  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. ...

How can I tell which sites are causing problems? You think it's gmail itself?